WD My Passport 0730 NOT SHOWING UP. Please help!

Recently I bought a WD My Passport 0730. I have been using it with my Macbook Pro with Retina Display (Late 2013 Model) Running OS X Mavericks 10.9.2. I always safley eject it before removing it, and have not dropped it.

A few weeks ago, I turned on my Mac and connected the external hard drive. It would not show up on the desktop, or in finder. I went to disk utility and found that it was called " disk1s2 ". It was previously called " Ben HDD ". I tried to mount the drive first, then the partition called disk1s2, both with no sucess.


 <(below): Partition One (Ben HDD) Info>

After keeping it plugged into the computer for a very long time (2-4 hrs), I noticed that “Ben HDD” had appeared on my desktop. I tried to open it, but that crashed finder. I then attempted a disk repair using OS X’s built in Disk Utilty, but with no sucess. The mac eventually was able to open the disk, but would only show folders, not the contents of the folder. 

I then used a program called “Disk Drill” to try and get the files back off the hard drive. It was able to recover some of the files, but not all. It took 22 hours to recover about 5 gb of data out of about 600 gb. After recovering some of the data, Disk Drill crashed. After 22 hours it always crashes. The next day I got this info off of disk drill:

Scince this, I have used many recovery programs. I have tried recovery with a PC and with Linux. Nothing has worked. 

I REALLY need the files from this, and more importantly, i need it to work. 

If anyone could PLEASE help, I would be very greatful.:stuck_out_tongue:


I still can’t format the drive, erase the files or use it for anything. I’m never buying WD again. “Put your life on it” they say. Pity it breaks in 5 days.