WD My net N900 central with internal HD media server issues

#1

Hi,

I recently purchased a WD my net N900 central with 1tb internal since my apple time capsule fried its own power supply. The intention was to use it as my previous time capsule, map the network drive and flawlessly enable to stream and copy media from the n900 central to any of the connected media storage (for instance my second time capsule or apple tv). Now I have connected it and plugged in the ethernet line in the internet socket, I have then setup everything in the setup part. It has internet, and is also distributing wireless AP. All that is fine though the problem is that I am unable to access the internal drive of the N900 without being connected to the wireless AP of the N900… Since I already have another time capsule I want to stay connected to that wirelessly and then connect/communicate with the N900 through this. Now here is the strange thing, I can ping the N900 central while being connected wirelessly on the time capsule but cannot access its internal hard drive or map it. Then it sort of just acts as a dead media storage. I¨m also unable to find the N900 internal hard drive through other units like Apple TV. Any tips would be greatly appricated.

#2

Hello,

Have you tried performing a restore on the internal hard drive using the dashboard of the router?

#3

Hello,

Yes I tried restoring the hard drive, gives me the following error;

Firmware Check Fail

The Network may be Disconnected or the Download Speed is Too Slow.

Which is kinda weird since Im hooked in on a fiber optic line with ~100mb/s transfer rate.

I did format it successfully though.

#4

Telnet to your N900 Central by following these instructions

cd /etc/scripts
./restore_hard_drive.sh partition_hd

WARNING: this will wipe out everything on the internal HDD, of course.

This way you bypass the faulty firmware check of the Web UI and force your internal HDD to be repartitioned.