WD My Could Home 12TB issues and solutions

Hi all,

This may be a rather long post, but I had quite a few frustrations with this product (WDBMUT0120JWT) over few years and I am really giving up on it. At first, I blamed my set-up, later the device itself, decided it is simply bad design and almost found a way to live with it, but now I am just thinking maybe I missed something and there is something very obvious (or maybe not so obvious) that I have missed.

To begin with… my expectations when buying this device probably were too high, but technically I don’t see anything I misjudged in particular. What I expected is that I can use this as a consumer-grade NAS “dump” for my data. Nothing fancy, but reliable 12TB in JBOD was certainly enough for me, I don’t need extra protection from RAID1 either as I do back-up in my main PC and this drive would keep “back-up of back-up” at best, but mostly just raw video, pictures, software installs and similar low importance stuff. Further, the “cloud” functionality would allow me to access that “dump” from anywhere in the world as a nice bonus.
The device has 1Gbps connection in theory allowing 125MB/s transfer speeds (say 110-115MB/s considering overheads), it has 2x6TB WD Red drivers (potentially WD60EFZX or EFRX) capable of ~185MB/s random write speed each. I did realise this drive does not support RAID 0 for some weird reason, but it should not be an issue in theory even running it on allowed JBOD and RAID 1 options as it would be capped at 125MB/s by ethernet interface anyway.

Where theory meets reality… So I got the drive and started “dumping” stuff on it. Across dozen devices, I had ~6-8TB of data, but loads of duplication as well.
Issue number 1:
It never reached 125MB/s speed… and most of the time it would literally go into low KB/s, when I tried to copy my foto gallery (~80GB) it took days to finish it. I didn’t even bother with WI-FI transfers as it would be stuck for days without any progress. Once I tried uploading like 300MB install file and it took 4hours… forget it!
Issue number 2:
When encountering duplicates device would literally stop copying for hours at a time e.g. if I had the same folder names copied from one PC and I try to copy the same duplicate folder from another PC and expect it to merge, it would take hours for each folder.
Issue number 3:
When left drive to its own ways copying data for days or even weeks, it would start crashing and restarting, leaving me guessing what was copied and what was left. So I started copying folder by folder taking 4-8 hours, instead of days at the time… “mild” inconvenience I guess.

So I thought, maybe it was meant to run in RAID 1 (I believe that was default out of the box), At the end of the day 6TB was probably enough if I keep some data on my main PC and do some de-duplication… so I set it to RAID 1.
Issue number 4:
The device started dropping partitions. At first, it would just crash, but later it would just drop the entire partition and would require a full reset to factory setting and reformat. It seems I have not lost anything in particular, but frankly, I don’t know. It seems that if there is a single key requirement for such drive, especially when set to RAID 1, then it would be “secure data storage” and this drive fails even that.

Few things I tried, was changing switches and routers to see if it is a network issue and nothing helped. I have tried doing all sorts of tests on my PCs, checking if that could be an issue with my internal drives… but no, they would copy data at nice and reliable speeds well in excess of 125MB/s network cap. Write on my own HDDs was ~180-220MB/s, read 240-280MB/s… and when copying data into SSD I had no issues hitting maximum advertised speeds of 480-560MB/s. Equally, copying from one PC to another directly via the network I had no issues hitting 125MB/s (I think it was stable 119MB/s on 1Gbps via switch and 240MB/s via direct internet cable as both PCs had 2.5Gbps NIC).
In conclusion, it was certainly not an issue with my network or system.

Whilst I was trying to figure out what is wrong with this thing my Amazon 30 days return policy has expired and to be fair I don’t know why I never considered returning it as faulty, but now it is too late for this anyway.

Eventually, I changed it back to 12TB JBOD, and once most of the data was transferred, the daily and weekly increase in stuff wasn’t really that huge to take excessive amounts of time to transfer. I noticed that large and well-compressed files would actually copy at ~100MB/s reliably, so it just proved there was nothing wrong with the set-up itself. However, smaller files were particularly painful (not that I consider 8-14MB HD pictures small files from the perspective of a file system). Overall, it became a “dump” of data as I wanted, just significantly slower and less useful than I have ever imagined. I kind of left it at that, but over few years I am still getting frustrated with it…

  • it takes forever to find the data
  • it is slow even when reading
  • it doesn’t work that well with mobile devices or over 4G/WI-FI
  • most apps don’t actually recognise it as a network drive, so I can’t actually use it for incremental or differential back-ups. WD backup facility is completely useless and amazingly slow.
  • shared links are a pain to manage, add, remove etc.
  • giving access to other users via their own accounts and managing them is as well painful
  • I have to use WD discover all the time and it keeps crashing, forgetting passwords etc. sometimes it refuses to log in even with the correct password …

I tried to understand what causes all these issues and I came to the conclusion issues are to some degree related to the following issues:

  • poorly implemented software, just slow, clunky and unreliable on both Windows and Android.
  • whatever technology runs the enclosure is sub-par, meaning that even if the software is updated it is simply too weak to run higher capacity drives.
  • likewise, it probably forced WD to use a subpar interface i.e. 1Gbps ethernet and no RAID 0.
  • KDDFS file system… I believe this could be one or even the main issue… especially where compatibility, reliability and performance are concerned. WD… why not exFAT… maybe?!
  • abysmal random seek speeds, probably as a result of the point above. For example, even when simply deleting files e.g. 5000 pictures it takes hours and it deletes at abysmal 2 files per second! So whatever is controlling those WD Reds is crazy slow. I just can’t believe WD Red drives themselves are so slow. Again maybe that is KDDFS? Maybe Windows just does not like it?
  • fundamentally flawed access, which required internet access to log in to WD Home Cloud page, instead of having direct access by default and “Cloud” access as an option.
    In short, it is not acceptable, especially for a rather expensive device from one of the market leaders (WD).

So recently I decided I have to do something with it, because it really annoys me just looking at it! So I decided to take drivers out of the enclosure and just put them into my PC. At least I will get all 12TB and I could even set it to RAID 0, it will be connected via SATA 3, so in theory, I will have 12Gbps on tap or whatever combined speed of drives is, but certainly, more than 125MB/s is and definitely more than 12KB/s which I sadly have seen several times. Really just could not see any downside of doing this, apart from losing cloud connection which frankly isn’t working nor worthy…

Now… before ripping the whole thing apart… I just thought… maybe I am doing something wrong and it is just my incompetence? Does everyone have the same (terrible) experience with these drives?
Obviously, I doubt that I would damage something as drives are actually meant to be taken out and could be replaced, the enclosure itself could be sold. Perhaps if somebody would fit 2x500GB drives the issues I am experiencing would be much less of an issue? Maybe there are other ways to make this thing more useful… like maybe I can put Linux or Android on it, convert drives to exFAT, ZFS or NTFS.

Any feedback or ideas would be welcome!


They could more likely be WD60EFAX usually used in the My Cloud Home (MCH) line of products. Since the WD?0EFAX series are SMR drives which is increasing becoming questionable for NAS use because of sector read errors associated with the WDC firmware, that could also slow the performance of the unit. You can read and identify the model you have in your MCH without taking apart the unit by reading the debug_logs.zip file and look under the kernel or /pstore/smartctl logs. I can write up something on this.

Thanks… It may indeed be WD60EFAX. I have looked into logs, but sadly I can’t find any such information there. there is no smartctl log in pstore. Overall looking into the logs there are millions of errors… obviously, I am not sure how critical they are for performance, but it is continuously pinging different errors of various types.

That said - does it actually change anything I have mentioned above? Or with my plans of taking the thing apart. Would it work significantly better with different drives? Would it make difference whenever I fit WD60EFZX, EFRX or EFAX into my PC?

Hi, again - I wanted to create new topic, but for some reason I can’t (it just greyed-out).

So maybe I can just ask question here as it relates generally to horrible experience I have with this drive.

Two days ago I tried accessing the drive again and my WD Discovery app has logged me out again (just so annoying it does this all the time). Entered my credentials and they came back as incorrect, despite being 100% correct. Anyhow - managed to connect on the mycloudhome website, had to change my password again and it showed drive as empty. Just a single folder there called “family”.

Now this got me really scared. WD Discovery was showing capacity correctly i.e. 3.82TB free space out of ~10.81TB, but would not let me connect. The website allowed to connect but showed drive as empty.

As such I decided to restart the drive to see if this is just one of dozen issues with how this thing syncs, but then I got message saying “upgrading, may take a while”. ■■■■ - thanks a lot WD for at least asking if I wanted to start update now!..

So it started updating and cut me off the access for my files without asking, but now for it has been doing this for 2 days! From time to time I hear sound reminiscent of HDD head clicking and I have blinking white light in the front.

Is there is anything I can do - priority being to keep the data safe, because last thing I want is for this piece of **** to drop ■■■■ partition on me with all the data in it. Has anyone recently gone through this update? And what a while means? Assuming this update as it says “completely rebuilding how data is stored” and I have like 8TB there… with speeds this thing is running at may take months. I mean again WD - thanks for asking me when to start, or offering to back-up in case of power drop in the period of months which may corrupt everything!

Any help would be appreciated.