WD My Cloud with WD Photos Android First Time Setup fail Galaxy S4

When trying to access the device hangs on first time set with error message “unable to access device”  The device shows in app and list the number of files.  Photos from the phone have been uploaded to the device.  WD My Cloud app connects fine, both remote and local.  I have tried removing, reinstalling,  restarting the device etc, but nothing works.   Shows up in the dashboard connected.  Device is connected with port forwarding

Hi jswinner, check the link below for some troubleshooting steps you can try.

[HOW-TO]: Troubleshooting Remote Connectivity Issues


Yes, all of the troubleshooting steps pass.  Note I can connect with the “WD My Cloud” app both internal and external.  I tried a tablet with WD photos, and it did not set up either.  There is some connectivity as it shows how many files are on the my cloud device and will upload, just will not display any photos.

Hi again, another troubleshooting step you can try is to disable and re-enable the Remote access. If the problem continues you can rebuilt the content database. See page 74/75 of the manual for more information. 


Problem continues after those steps.  Streams ok to DLNA clients