Wd My Cloud Windows 10 connection

#1

I am having problems connecting to My cloud since updating to window 10.
I have tried most if not all the remedies in this compilation. One more
thing I did is uninstall all the WD related software and only installed
WD mycloud application. Now my NAS is discoverable through application.
I can find the drive in windows explorer when both the laptop and drive
are connected with wires via router cum modem, only router at my home. I
can create a short cut, map the drive and access the drive by clicking
on desktop short cut and using mapped drive letter. When I remove the
wire, I am unable to connect to the drive via wireless. Still can
connect through WD Mycloud application. I am unable to stream music to
Bose soundtuch 20wireless speaker. Sound touch application on desktop
and on mobile is not finding any NAS on network. But I could connect to
NAS through Android phone whatever the status is, either wired or
wireless. I have MAC binded the NAS aswell

#2

Hi,

Have you tried resetting the unit? If not, please try that using the reset button on the back of the unit. Also to improve the connection, try setting the unit with a static ip and check the firewall settings on your router.

#3

By “this compilation” do you mean the following thread:
https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

Often when a My Cloud cannot be reached locally with a Windows computer it is due several factors, here are some of them:

  • The My Cloud IP Address has changed. To solve this issue assign the My Cloud a static IP address through the local network router or through the My Cloud Dashboard Settings page.
  • The Windows computer has NetBios over TCP/IP disabled. If this is the case, enable it. Otherwise browsing for network devices is limited or not possible.
  • The Windows computer has its Network Location configured to Public. If this is the case change the network location to Private or Home.
#4

Thank for your reply.Whatever, I did was after reseting. I have tried static IP method. Didn’t work. Later left it as DHCP but bindesh the mac I’d to IP. This is almost static IP. What I don’t understand is laptop can recognise NAS when connected with wire but not in wireless mode.Regards

#5

I did all these things.

#6

Check the IP addresses allocated to the wired (Ethernet) port and the WiFi port on the PC. They will be different (because they have different MAC addresses). Check that they are on the same subnet.