WD My Cloud & Twonky Server


This drive is awesome for now, everything works smooth as i like, but i have one issue with my DLNA server. I have new Samsung TV SUHD UE55JS9002 Series 9 which is running on Tizen OS. There are no subtitles when i stream movies over DLNA, with the current version on the WD firmware which is 7.2.9-6_7.5.0-77. However, i installed trial version of the newest Twonky Server on my laptop just to see if the problem will go away, and voila, the problem goes away with the newest version of Twonky Server (8+ version). Same drive, same movie, same subtitle, everything’s the same.

Is there any good tutorial how to upgrade to the newest version, even if i have to pay for license, i will pay just to go away this issue. I’ve tried few of them but i got errors when i try to run the TwonkyServer.

Here is my current firmware: v04.04.02-105



I managed to udpate TwonkyMedia to 8, and now everything’s fine. Here’s how:

You login via SSH and type this commands:

First, we stop the TwonkyServer:

/etc/init.d/twonky stop

Then we go to this directory:

cd /usr/local/

You’ll see twonkymedia-7 there, and what we gonna do is we gonna replace all the files of tonkymedia-7 with Twonky 8, but remember, make a backup of it, just in case, so next command is to make a backup:

cp -a twonkymedia-7/ /usr/local/twonkybackup

Next, we enter the twonkymedia-7 directory:

cd twonkymedia-7

Now we remove everything here:

rm -rf *

Now we download the newest version for firmware WD 04:

wget http://www.twonkyforum.com/downloads/8.2.1/twonky-WD_MyCloud_04.xx.xx-arm-8.2.1.zip

Next we do unzip:

unzip twonky-WD_MyCloud_04.xx.xx-arm-8.2.1.zip

And now we run the server again:

/etc/init.d/twonky start

Works smooth, no problems. Now you will need license key to buy. :slight_smile:

1 Like

Have you checked the My Cloud Twonky Administration page (wdmycloud:9000) to ensure the Twonky Media Server is using the correct Media Receiver?

If you do a search through these forums you’ll see that some have trouble with SRT subtitle files while others (myself included) do not. As always ensure the SRT file is the exact same name as the movie file its for. For some reason Samsung seem to be one TV manufacturer that comes up often as having trouble with the My Cloud.

I’ve tried everything, nothing helps. If we find a way to update to the latest version, issue goes away.

This was discussed in a recent thread.

There are instructions for installing a MyCloud build on the twonky forum. I added some pointers to the Twonky FAQ, but I haven’t tried it.

I just found out that on the latest TwonkyServer (8 version) my tv is recognized as Samsung J Series, but on this WD firmwares is recognized as Samsung Smart TV.

Also i noticed that there are a lot of more TV profiles on the latest version. I’ve trited everything to update but i’m not able. I’m doing something wrong.

I’ve made a backup of my original installation, replaced all files there with twonky 8, the UI recognized as 8 version but coudn’t start up, i’m sure there is something i’m missing and that’s why.

Can anyone help?

Well, the OP of the Twonky upgrade thread has just replied to say they were successful; try posting on that thread to see if you can get advice.

As for the updated profiles, I suspect that you should be able to extract them from the Twonky 8 install package, and copy them into the Twonky 7 directory (profiles are just simple XML). I discuss this possibility, and where they need to be placed in the FAQ: have you read it yet?

Just an update people! I updated the first post, i managed to update to the latest version!!! :slight_smile:

1 Like

Good. Hopefully it will help others who have trouble with Samsung TV’s.

Note post edited, for some reason the update to the OP post wasn’t showing on my end.

That’s good, but I’d still suggest people try to update just the device profiles first, to save having to pay for a licence…

Download the Twonky version zip file
Open zip file
Extract the device profile database
Copy the device profiles into the existing installation:
Probably wise to take a copy of devicedb beforehand…

I’ve tried that, it’s not gonna work. :slight_smile:

Okay, thanks. I don’t have a Samsung TV, or any SRT files, so I couldn’t try it out…

Hi guys

I bought a new mycloud 4tb nas firmware version 2.11.
Within it there is a twonky version 7, but I would to update it to the 8.3 version (I already bought a product key).

I followed the below instructions (used for my book live with success):

disable dnla server within mycloud web interface
enable ssh within mycloud web interface

into SSH shell
/etc/init.d/twonky stop
cd /usr/local/twonky
cp -a /usr/local/twonky /usr/local/twonkybackup
wget http://www.twonkyforum.com/downloads/8.3/twonky-WD_MyCloud_02.xx.xx-arm-8.3.zip
unzip twonky-WD_MyCloud_02.xx.xx-arm-8.3.zip
/etc/init.d/twonky start

but I met some problems.

1 - the instructions “/etc/init.d/twonky stop” and “/etc/init.d/twonky start” doesn’t work.
2 - after the reboot all files come back to the default. eg. no backup folder, no new version of the twonky.

someone can help me to the correct way?

thanks a lot.

Did you try the OP’s method of updating? The OP removed the files from the twoknkymedia-7 folder before doing the wget and unzipping the files.

Next, we enter the twonkymedia-7 directory:

cd twonkymedia-7

Now we remove everything here:

rm -rf *

You may need to be IN the twonkymedia-7 directory (or what ever directory is correct on the v2.x firmware) when you using the wget command and unzip the files otherwise the files may be unzipped into the wrong directory/location.

Hi Bennor.
Yes for both questions.

I deleted all the files into the twonky directory, and lunched the wget command within the same directory.
The new files were into the right directory.
The problem is after the reboot of mycloud

Those commands are relevant to a Debian Linux installation.
Since you appear to have a Gen2, v2.x.x firmware MyCloud, which is based on BusyBox, they probably don’t work. You should be able to ls /etc/init.d to see if it exists; I suspect it may not.

Gen2 devices are much more ‘locked down’ than Gen1 devices, I think.

Since someone at the Twonky forum obviously thinks they know how to compile for a v2 firmware MyCloud, it might be worth asking on the Twonky forum. Or searching here for how to install third party software onto the Gen2 MyCloud.


the path /etc/init.d exists.
but inside it there is nothing about twonky

I asked to the twonky forum, but I’m waiting.
Someone seems found a solution, but not very clear.

Need to do the same. Would you provide simple instruction for someone who has no idea of SSH? How to login via SSH?
How to copy paste file to twonkymedia-7 folder?
Appreciate really simple guide

Enable SSH via the Dashboard.
Login using a utility like PuTTY.
Run the commands above to install Twonky.

Assuming you have a Gen1/v4 MyCloud…

Did it using terminal on my mac.
However I have most likely Gen2 devise as my firmware starts with 2.11.142. Can you confirm if this is right assumption?
If yes, is there any way to upgrade Twonky to 8.x on my device? Twonky publish this software version so they assume this is possible. I just do not know how. Simple step instruction would be highly appreciated.

Yes, you have a Gen2 device.
No, I don’t have a Gen2 device, and haven’t updated twonky on my Gen1, so I can’t help.