WD My Cloud randomly wakes up the drive when Drive Sleep is enabled


#62

It was running for around 5 minutes. I wanted to first test if the script detects files accessed from SMB shares.

I’ve good news: I think I detected what caused this problem.
It was either:

  • Stopped cron (I resumed yesterday to let it run for a full day)
  • External NAS device with OpenMediaVault. I restarted it before night. Not sure if it was the issue, but I’ll be observing it more.

Seems like it helped:

2019-04-12T07:09:15.645208+02:00 di=H10IhkTgem notice logger: exit standby after 13416 (since 2019-04-12 03:25:39.760101001 +0200)
2019-04-12T08:01:09.496722+02:00 di=H10IhkTgem notice logger: exit standby after 2503 (since 2019-04-12 07:19:26.880101001 +0200)
2019-04-12T08:01:19.212473+02:00 di=H10IhkTgem notice logger: Rotated atop, atop_size=3055062 atop_upload_size=1065
2019-04-12T08:12:11.661327+02:00 di=H10IhkTgem notice logger: exit standby after 51 (since 2019-04-12 08:11:20.670101001 +0200)
2019-04-12T08:26:19.178958+02:00 di=H10IhkTgem notice logger: exit standby after 237 (since 2019-04-12 08:22:22.710101001 +0200)
2019-04-12T11:48:48.555133+02:00 di=H10IhkTgem notice logger: exit standby after 11538 (since 2019-04-12 08:36:30.300101001 +0200)

Thanks for help.

One more question, I know that “chroot” exists, which would prevent those random wake-ups. Does anyone know if it has the “full” WD firmware running on it? Would it lose files/shares after installing? (I have full backups, but still restoring takes a very long time).


#63

chroot is a program. It does not contain any firmware. Using chroot you could mount a USB device with different firmware. Then you chroot to the USB. Now anything you run will use the USB code to run. IF you want to play with chroot google chroot. There are several things you need to setup to be able to have access to your data files from the chroot environment.


#64

Back in the days I suspected OpenVPN which I believe is the link between your cloud and WD Servers, on trying to connect.

After killing that service, by issuing
killall openvpn
(I believe as it has been a year since I last looked at this)

My Cloud seems to settle down.

Alternatively, rebooting the my cloud from time to time seems to settle it down also.

This is all I have from my memories…

Good luck

@rac8006 you should check if whether DHCP renew wakes up the cloud. This is something that is always in the back of my mind but I keep forgetting to mention it as one of the wake up factors.


#65

I have not done much wok on the My Clouds lately. I’m in the process of making an older PC that I have been using to rebuild My Cloud software into a nas. It currently has a 4TB system disk and a 8TB mirror for my data. I.m about ready to take the two 6TB disk from my two clouds and put them in as a 6TB mirror. It has more cpus and memory than the clouds.


#66

Interesting, run that command on my first gen and it indicates “openvpn: no process found”. I have remote access turned off in the Dashboard.


#67

then there won’t be any openvpn :stuck_out_tongue:

I do remember a scenario when the WD servers were going up and down for some strange reason and My Cloud would wake every 30 minutes exactly on the dot.

I had suspected that once you are connected to WD they get to watch all your movies on your drive.

Good luck rac8006.

I had a bunch of Shuttles back in the day and even then they are big in comparison to a tiny Cloud.

A Raspberry Pi would make a great NAS. The problem with a Raspberry Pi would be all the cords dangling from the motherboard to the Hard Drives.

Thus I prefer that all-in-one QNAPs of which mine was only about $350 giving me 24TB raid 6.


#68

The obvious cause is the system pushing something out to swap. These are memory constrained devices with things running, and likely have the swappiness value turned to something lower than defaults. (meaning it prefers to put things into swap)

this means that when something needs to be pulled back from swap, or paged out to swap, the drive will wake to service the system call.

This is one of the major reasons I wish WD had not been tools, and had included zram in the firmware. (also btrfs. ■■■■, btrfs with zstd compression would be glorious on a NAS.)

One of these days I will get around to testing sata port replicators on my EX2…


#69

If the Pi had SATA port(s) then it would make a potentially good NAS assuming those ports didn’t share the USB pipeline. The main drawback with using the Pi is not the bundle of cords, its the hardware that uses the USB lane for both Ethernet and USB hard drives. For example on the Pi 3 B Plus the hard drive and network transfer speeds are capped by the shared use of the USB 2.0 speed. The Pi can be used as an NAS but it has some significant drawbacks for the time being. Currently I use the Pi as a Plex server (and to run other modules). I don’t really use it as an NAS even though I have an old 750 GB USB hard drive hanging off it and have Samba enabled on the Pi.

Right now as a pure NAS, the My Cloud operates better than a Pi when it comes to file transfer performance.

Some speed comparison on a laptop using a USB 3.0 to Ethernet adapter to copy files to a Pi 3 B Plus and to a My Cloud. The My Cloud is significantly faster.

Raspberry Pi:
Pi

My Cloud:
2

Note don’t get me wrong about the Pi. I like them, I run two currently. It has it’s uses but for being a pure NAS it has one or two significant drawbacks.


#70

i use “Odroid XU4” as the second NAS (but there are currently newer models which work even better). It costs more than Pi, but it’s great. It has 2x USB3.0 and 1Gbs Ethernet. After minor tweaks to EXT4 mount settings (copied from MyCloud) I’m getting even better speeds from my external USB3.0 Wd My Book. NTFS speed (another My Book device formatted to this format) with “bigwrites” mount settings works much better than MyCloud, basically allows full speed. What’s beautiful is that external drives never wake up, because the whole system is on a micro-SD card. Not to mention that this device has 8 CPU cores and 2GB RAM, so simultaneous transfers are not a problem like on MyCloud. Also, when needed AES encryption/decryption works pretty fast, so could create protected volumes (however newer Odroid models than XU4 are better for it).

EDIT:
Test Results

MyCloud (internal drive):


(don’t know why read speeds for 4KiB Q8T8 and lower are so low. I repeated the test with same results)

XU4 with external Wd My Book formatted to EXT4:

XU4 with external Wd My Book formatted to NTFS:


#71

ahhh yes you need at minimum of USB 3.0 for a NAS to be more viable but still what you are getting isn’t too bad.

ok this has more CPU cores than my Gaming PC.

I do like the size of the ODROID-XU4 but I hate the huge fan.


#72

The speed isn’t too bad (for what it is) but it’s not enough if you are trying to stream more than one stream. Generally I only get frustrated with Raspberry Pi Samba USB 2.0 speed when transferring several large files. For a small number of small files it’s fine as an NAS.

In my case I run; Plex, Forked-Daapd, COPS (eBook server), Samba and Pi-Hole on that Pi-3B+. The Plex, Forked-Daapd and COPS all access the first gen My Cloud for it’s media storage/use. Works fairly well for individual low usage when streaming but if I try to do transcoding or stream more than one stream or do anything else that taxes the USB 2.0 throughput things typically gets squirly.


#73

They have a version without the fan, called “ODROID-XU4Q” (currently $49.00), but there are some negative opinions about throttling. The new one is “ODROID-N2” with 2GB or 4GB of RAM. Benchmarks look amazing. It has a better DC than XU4 (12V/2A vs 5V/4A), 4 USB 3.0 ports. A nice toy to have, which can be used for many more things than just NAS. I have openmediavault, pihole, Plex, Rsync and stuff like this.