WD My Cloud problem

#1

Hi. Im having problems again with WD My Cloud. Before I had a problem with my IP.
That was corrected to make a static ip. Since then it worked good. I recently moved to a new place and i connected and hooked up everything the same as before but now when click on WD My Coud Public Share nothing happens. My firmware is upto date. Can someone tell me what is going on and how can I fix it. Thank you

#2

Are you clicking on a “mapped” Share when you say you " click on WD My Coud Public Share nothing happens"? If so then remove the mapped Share and create a new mapped Share.

Can you reach the My Cloud using Windows File Explorer or Mac Finder?

Its possible the local network IP address’s have changed which would make reaching the My Cloud difficult. It is generally recommended one configure the static IP address for the My Cloud by reserving the IP address within the local network router and not within the My Cloud itself.

You may have to perform a 4 second reset via the reset button on the back of the My Cloud which will reset the admin password to blank/default and change the DHCP setting of the My Cloud back to auto.

#3

Right now I can’t reach My Cloud using Windows File Explorer. How do i remove the mapped share.
And to create a new mapped share follow these instructions. Im on win10 http://support.wdc.com/knowledgebase/answer.aspx?ID=2676#win10_1

So in the manual mapping option 2 where it says “What network folder would you like to map” Pick drive W like it says there and the folder \wdmycloudex2100\public? or for folder write my 192.168.0.15 ip?

And what about the 4 second reset. Should I do it if the mapping works?

#4

To remove a mapped drive in Windows 10, using Windows File Explorer right click on the mapped drive and select Disconnect.

What My Cloud model do you have? Generally this subforum is for the single bay My Cloud units. If you have a EX2100 there is a separate subforum where people familiar with the EX2100 may be able to help.

https://community.wd.com/c/network-attached-storage/my-cloud-expert-series

If Windows 10 isn’t seeing the My Cloud in Windows File explorer then check to ensure NetBIOS over TCP/IP is enabled within Windows, also ensure the network is set to Private not Public. How to check both are explained in the following thread:

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

When mapping the My Cloud you generally navigate to a specific Share on the My Cloud that you select and then map.

A 4 second My Cloud reset will reset the administrator password to default (blank) and the DHCP setting to Auto.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

#5

My model is WDBCTL0020HWT