WD MY CLOUD not visible in the network

Hi, i recently bought a WD My Cloud 2TB second hand, and when it arrived i tried hook it up as in the starting guide, first on the power then on the network but the Orange light is blinking, i looked on the back of the NAS and i have no lights in the ethernet port.
I switch to all the port of the router its a D-Link DIR-842 and still no lights on the back.
Also i switch to the tenda switch i have and i still have the same result the orange light and no light on the back
Tried few different cables and i know that they are working and still no luck

I tried pressing the reset button 4 sec. The led is blinking during and after the reset… like nothing change
I tried the 40+ reset but nothing changed, like then it powers on its like a normal power on till the 40+ seconds pass the led start blinking in orange again.
Any idea what can I do?

Do you have a single bay My Cloud or did you obtain a multi bay unit? Does it look like this:

What happens if you connect the My Cloud direct to your computer or put a network switch between the My Cloud and the router? Do the LED lights on the My Cloud Ethernet port light up?

If you look at the bottom of the My Cloud unit it should have a P/N number, what are the last two digits of that number? “-00” means first gen single bay My Cloud, “-10” means second gen My Cloud.

Because you bought it second hand, did you verify - in person- that the device worked before you purchased it?

Obviously when buying something used there exists the possibility it may be broken or because it has a hard drive, the hard drive might be damaged/non functional. One troubleshooting step is to remove the My Cloud hard drive from it’s enclosure and connect it (using a USB to SATA adapter/dock, or a spare SATA port on the PC) to a computer running Linux, or use a third party Linux driver on a Windows computer.


It has 00 at the end of the P/N code.
And it’s a single bay unit like the picture you attach.
I tried to connect it to a tenda switch I got the same thing.
The seller show me a video that he was connected to it before sending it to me.

Should I try to open and connect the HDD directly or it’s a problem of the lan connector?
So assuming if the hdd was broke, shouldn’t have the lights on the back still on when I plug the internet cables?

Generally the LED lights on the My Cloud Ethernet port should light up indicating a connection. Could the My Cloud network port be bad or defective? Possibly.

Removing the hard drive from the My Cloud enclosure is an option. One will need a spare SATA port on their computer or use a USB to SATA adapter/docking station. Note that the My Cloud hard drive is formatted for Linux so one will need to use either Linux or Linux drivers for windows to see the various partitions and their contents.

Thanks Bennor for this advice, I thought will be something else like a setting or something to remake the land connection, i think i will return the product and get something else. otherwise, i will just use it as a internal hard drive.

But I think the board got damaged, somehow on the transportation i dont want to open it if i can just return it, if not i will try to open and clear the connection on the board maybe is something from there.

than strange thing is that i send it back to the guy i bought from, and he has all the lights on on the back of the my cloud, also blue light instead of orange in the front.
He has a apple router, i tried on a D-Link router, TP-link router, Huaway router, Tenda switch, and with 8 different cables that i test before each cable cat 5e, with non of them worked, any idea why this happened?