WD My Cloud Not Showing Up As Computer

#1

My Cloud will show up as a Media Device and Storage when I click on “Networks” in file explorer, but no matter what I do, I cannot get it to show up as a computer like it did on my old laptop. (My new one is Windows 10, my old one was Windows 7.) I did EVERYTHING in the “Compilation of Windows 10 Methods, Steps, and Solutions” thread (except the Powershell thing because I couldn’t get it to work) and its still not there.

It will open my folders if I go to “My PC” and click the cloud there, but anything I click it downloads, and it will only get pictures and music… you can’t even find documents, and its all organized very differently than it actually is on the cloud itself. (When I was going through the 10 Methods… at one point this option WAS organized exactly how I had everything and let me access everything, though I did still have to download and couldn’t add files.

No idea why it stopped doing that.) Also, I tried removing my current tablet as a device on the cloud… I removed my “Windows 8” device (when I initially installed it, that’s what I was running), but everything still works exactly the same and it never prompted me for a new code.

Please help! I’ve been messing around for the past 2 hours trying to fix this…

#2

The problem is with Windows 10. Generally changing the SMB within Windows 10 will solve the problem, or setting another device on the local network as the Samba Master Browser will fix the issue. Both are explained in the Compilation of Windows 10 Methods, Steps, and Solutions thread.

Or you can simply just map those folders/Shares that you need by using either the IP address or the My Cloud name in the Windows File Explorer address bar to open the My Cloud.
For example:
\\wdmycloud
\\192.168.1.2

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=2676

#3

The IP address does actually work, and it lets me add files, modify files, etc. I just know under Windows 7 it used to show up under “computers” so when I didn’t see it there, I figured there wasn’t any other way to access it this way. Thank you!

I did try all the SMB stuff and it didn’t make a difference … :frowning: