Wd my cloud link problem

hey all 

i bought WD my cloud and connect it to my router and I had local access to it , I tried to open it from IP or hostname and it didn’t work at all.

I tried the WD apps and select the WD mycloud in my network but it told me that there is error and I can’t edit the settings  etc. so I rested the device but same problem still there .

I can’t create accounts or edit the permissions on it

I checked the ip manytimes incase it changed but its the same.

what you suggest me to do in this case?

waiting your kind reply 

Login to your router, can you see wdmycloud connected and active?

yes it’s active , but the problem is that I can’t access to the Dashboard .

this is what I get when I trying to setup wd my cloud .

Frankly I never used those apps. But can you ping from your PC to the MyCloud hostname or IP? If yes, can you also reach the MyCloud’s _ port 80 _? One method is to use netcat or telnet such as below. On windows command prompt telnet, you should get a blank screen which indicates the port 80 is reachable.

I tried the telnet and I couldn’t reach it , so I tried to reset it to factroy default “disconnect it and connect it again with 40 seconds holding the reset button” then I tried the telnet and its worked also the dashboard it worked also.

Thnx a lot man

appreciate your cooperation :smiley: