WD My Cloud Issues with Apple Time Machine

Hello All,

I got this message yesterday while attempting a routine Time Machine Backup over my network to a 3TB WD MyCloud. I have never seen this message before and from what I’ve found with a simple Google search, this is not good. Has anyone been able to resolve this issue without having to start a new Backup and completely overwrite your existing backup history? Also, does anyone know the root of the problem? In the event I start my Time Machine backups from scratch, what’s preventing this from happening again? It seems like this is a recurring issue with WD devices being used for Time Machine and Neither Apple nor WD is addressing the issue. Has anyone developed a solution or workaround for this?

A couple things I’ve tried:

  • Updated the drives firmware

  • Ran all available diagnostics (everything looks good)

  • Attempted a couple fixes through terminal however all have been unsuccessful

          Heres the link to the terminal fix I attempted. It’s a little dated so I’m wondering if the reason it’s not working is because of Mavericks…

http://www.garth.org/archives/2011,08,27,169,fix-time-machine-sparsebundle-nas-b ased-backup-errors.html

I’ve attached a screenshot of the message I’m receiving.

Thanks again!

Screen Shot 2014-07-19 at 8.12.53.png

MacBook Pro (Retina, Mid 2012), OS X Mavericks (10.9.2), i7-16GB-500GB

Are you running your time machine over Wifi? Several users report chronic issues with continuous or manual Time Machine Backups over Wifi…

Regardless, this error is relatively common and you don’t have any option except doing a new backup… It is a bummer to lose older versions of files, but if this is critical to you, you should consider using backup solutions for files that leave the files “flat” in the backup directory (for example, on Windows 8, File History does this very well). This avoids that, when the container of the backup is broken, you don’t lose all your backups, like here.

Note that I run Time Machine from Mavericks manually and I never had any issues over WiFi

Thanks for your response.

I have in fact been completing TM backups over wifi with no issues until now. I do clone my Mac once a month as another backup measure but really loved the convenience of TMs incremental daily backups. Please understand that this issue is incredibly frustrating for me because it seems that both Apple and WD are rather complacent with this issue - neither seem to be addressing the compatibility issue, despite WD marketing this product towards Mac users who use TM. To me, simply saying ‘it doesn’t work and there is no solution’ is unacceptable. 

I’m going to continue troubleshoting this issue. 

Thanks again for your input, Etupes. Much appreciated.