WD My cloud is not visible in DHCP table in router

WD My cloud is not visible in DHCP table in router. The LED is lighting blue. I tried power cycle and nothing change even after restarting the router and changing the network cable.

Any suggestions?

Exactly what DHCP table? leases? Pre-allocated DHCP addresses? A bit more specific info might help.

To find exactly what you have on your LAN download the program Advanced IP Scanner (link below). It will quickly list all devices that are on the LAN and are discoverable.



The DHCP table shows the hosts use DHCP protocol to get IP on the network. I tried also WD Discovery application and the suggested tool, both didn’t find MyCloud.

What router do you have? The more info you provide the easier it is for someone to help you.

What do you have chosen in the Dashboard under Settings>Network>Network Services, Static or DHCP?


It was working on the same router for several months (Huawei router). I remember that WD My Cloud is using DHCP in setting which is the default setting.

One other point is that auto update is enabled and it updates several times. The last firmware successfully update is at 01-29-2016 06:53:45 PM, Firmware version: 04.04.02-105. And it works after the update for several days then it stops working.