WD My Cloud Home Device Offline


Same problem here i can work like that any Solution on this ?


After all this problems and no solution



same problem here, so far no solution from WD.
No connection and slow breathing LED.


  • different router on different network
  • different RJ45 cables
  • resetting both router and my cloud home several times
1 Like

Same problem here:

WD My Cloud Home 4 TB.

Bought over a month ago and was working great. I reset my router Saturday and today i noticed we couldn’t access the drive through the website remotely. It works when i access it locally through iPhone app and WDDiscovery, but not if connected to hotspot or other network.

Support was extremely unhelpful, it doesn’t seem like they know what they’re talking about.

After messing with some router settings a few times and logging out and back in on the website, the files showed up again briefly and then when i went to click on them or refresh, they were gone again.

Set up port forwarding to the device for 80 and 443 as Support asked me to.

Now they’re saying I should replace the device with a refurbished one under warranty. This is incredibly frustrating because we will have to back up all the files somewhere.

When I tried to fill out the RMA form online, it says the server is unresponsive and can’t send in a request at this time. I’m also worried that I’ll pay for the Advanced RMA and when in the old device it’ll get conveniently “lost” so they won’t refund my money.

Anyone get any solutions?


@andysutton2073 sounds like the network router default settings may be blocking or not allowing sustainable connections. Also, it’s not possible to port forward a My Cloud Home because the external port is assigned randomly (not static) which means that it can change on the next reboot and the port forward rule will be in valid.

  1. Remove the port forwarding rules on your network router for the MCH
  2. Ensure UPnP is enabled on the router and check the UPnP or connected devices table to see the external port of the MCH
  3. Check your router Firewall or Security rules are not restricting access by being set to High
  4. Check Parental Controls if you have such options enabled
  5. Power off and on the router
  6. Power off and on the MCH

I tried all that several times, also no router rules changed when i reset it it, it was basically just a reboot.

MCH phone support were the ones who told me to set up PF on 80 and 443 because they had me check them through portchecker and it showed them closed.

How do I view the external port of the MCH? I can’t seem to find that option. i have included 2 pictures of my router settings below.

1 Like

After having given up syncing it seems that like a lot I will also have to give up using my cloud home because of these constant disconnections. it is just unusable. I cannot understant that WD have produced such a poor product, so expensive for what it does, a shame.For the connection issue I have tried everything including static ip address, nothing works. Thanks to WD. NEVER BUY WD AGAIN.
If someone have heard of a miracle to fix this problem, I am interested … Thanks in advance …


Be careful, mine won’t turn on at all now. WD is SUPER unhelpful and wants you to pay to get it replaced and pay to get data recovered. DONT BUY WD!!!

1 Like

I have the older MyCloud Ex2. Same issue. The problem has been there, off and on, since the day I installed it a few years back. I’ve carefully followed every instruction and no matter what I do the status shows as “Offline”. The lights are solid. I can locally ping the device through the Command Console. I can ping it through the browser. It’s obviously “there” - except it isn’t so obvious to MyCloud.com.

It does have two nice 2TB WD Blue HDDs. Too bad I have three 1TB SSDs and one 500gb SDD and no HDDs on my rig.

There is an upside: I have a few books at one of my side desk. I have a cute WD MyCloud bookend brick to hold them against the wall. :slight_smile: