WD My Cloud hangs with external USB storage

I have WD My Book 2TB USB 3.0 essentail. If I connect this drive to USB port of My Cloud drive then My Cloud drive hangs.

If stops responding to Windows My Cloud application, ongoing data copy operation fails and user interface from web browser doesnt work.

Some of my observations:

  1. Router shows My cloud drive connectivity even if user interface is not responding.

  2. White LED lights keeps on blinking fast on external USB drive. (It indicates that My Cloud is accessing that drive). But functionality of My loud drive never resumes.

If I unplug external USB drive then My Cloud drive works well.

what is on the external drive? if there are a lot of files, especially media files it can take a long time to settle down

sounds like it is just scanning the drive. the mycloud is very low powered and a lot of activity can effectivly “hang” it. once things setle down performance should be ok

Yes that has lot of media file. I allowed 8 to 10 hours but it didnt recovered from that situation.

It looks like internal software is engaging 100% in media indexing.

Actually it should share some processing bandwidth for other operation.

Infact it should priotize network interface over media indexing.

I don’t know how to convey my inputs to WD developers.

Thanks for your inputs.

a lot of media could take days, unfortuantly

I agree it should do better at this. What firmware are you on? the 1st 1 or 2 of the v$ FW was really bad, it has gotten somewhat better

Are you going to use the WD mycloud or WD photos to access pictures? If not and you use SSH you could disable these processes, see below. to re-enable change stop to start and disable to enable

to stop them now

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

to keep from starting next boot

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

I had updated to 04.01.03.421.

Enabling SSH may void the warranty of the drive. In settings I had seen this option. But when I was trying to enable SSH, confirmation message popsup to intimate warranty may get void. So I havent changed anything.

Thanks for your valuable information.

WD is vauge about the “may” void the warentee

I assume it is because it is really easy to cause issues in Linux/Unix if you are not carfull. I have not heard of any case yet where they denied warentee coverage. I believe I recall one where additional software was installed and it bricked the bycould and the still honored it.

Proceede at you own risk and comfort level. It should settle down on its own given enough time. if you routinly change external drives with a lot of media waiting is probably not an option

Enabling SSH may void the warranty of the drive.

As Larry says, WD are very vague about SSH and the warranty. This is the only reference to SSH in the User Manual:

SSH

Important: Enable SSH only if you are very familiar with it.
Click ON to securely access your personal cloud and perform command-line operations via the Secured Shell (SSH) protocol.
SSH is disabled by default.

There’s no warranty warning there.  So am I supposed to telepathically know that there’s a warranty issue?  I mean, the user manual isn’t even supplied with the thing; I have to go looking for it.

Do I have to search for vague warnings in the bottom of a locked filing cabinet stuck in a disused lavatory with a sign on the door saying ‘Beware of the Leopard’?

http://www.planetclaire.org/quotes/hitchhikers/

What other things do I need to search for that might void the warranty?  Turning it on?  Connecting to it? etc. etc.

If I search the WD website, I find this:

http://wdc.custhelp.com/app/answers/detail/a_id/10435/p/247,487

Critical: The use of SSH (Secure Shell) can potentially harm the hard drive and could result in the drive and the data within it becoming inaccessible or lost. The use of SSH to tamper with the drive in order to modify or attempt to modify the device outside of the normal operation of the product will void the drive’s warranty.

<quote>

So, the question is, does invoking a feature, built in to the device, as supplied (SSH) void the warranty?  Does calling ‘normal’ service control functions in the linux system (as posted by Larry) void the warranty?  They’re fairly ‘normal’ system commands to stop and disable the optional services.  Services that, as supplied, essentially make the device unusable.

I’m not adding unauthorised software to the thing.  I’m not deleting software from the thing.  I’m simply turning off pointless services that I don’t need, that I should be able to control via the Dashboard.

As Larry says, you have to choose what you’re comfortable with.  I think it’s unreasonable to provide a facility (SSH), and then say using that facility will void the warranty, when you have to use that facility to make the drive work properly.  I’ve said it before; if the thing worked properly out of the box , we wouldn’t need to waste our time fiddling with linux via SSH login…

Thanks for detailed information.

I was trying couple of experiments with the drive.

Also I raised support case to WD.

Support executive informed that if external drive is occupied >90% then issue may occur.

Most of my drives are occupied >90%. So during call it was not possible to take backup so fast and test the solution.

Later I was vacenting drives and testing the solution. I found that if external attached drive is used < 65% then and then WD my cloud doesnt hang. As soon as external drive crosses 65% limit, MY Cloud drive stops responding to MY Cloud application and browser (WD Dash Board). I tested this many times. I tried to ping that drive from command prompt, it responds but user interface is hang.

In order to connect external drive why should I keep my drives empty to this extent?

Issue 2: I have seen that My Cloud fails to recognize FAT32.

In user manual of My Cloud on page 111 they have mentioned support for FAT32 but it doesnt work.

Issue 3: If I try to copy large data from My Clouds internal drive to USB attached (to NAS directly using USB 3.0) using My Cloud application then it returns Error Message “The following folder was not copied. This can occur if folder name was changed. Please try again”.

WD software is very poor. Frequent drive reboot is required inorder to work properly.

This is my 1st bad experiance with WD product.

Typically it is software related.

Hardware is really good. If I connect empty external drive and initiate data copy between My Cloud internal drive to USB attached external drive then it actually does amezing job. In task manager you can ideally see Gigabit ethernet port working. In my case it was almost going up to 600Mbps.

Hi ! I waited four (4) days before giving up on ‘build’ of my huge archive’s many, many media files. IIRC, I would have had needed several months for a full ‘build’…

With that 15 GB ‘tree’ safely relocated to a DLNA-off ‘share’ area, the public area’s family albums catalogued in seconds.

I have a 3TB My Cloud and when I attached a brand new 3TB My Book via the USB3 port, the My Cloud froze up and became invisible on the network.  There was no media on the My Book, so there was nothing for it to scan.  I have had an open case with WD since last year (also can’t set safepoints as they bomb out after a few GB).  WD knows about this issue and has done nothing about it since v4 firmware was released.

WD My Cloud hangs with external USB storage too

I have observed that if external drive is used less than 50-60% then My cloud works well. If it is more than that then it hangs within 2-3 minutes.

Can you confirm the same?

I have escalated this issue with WD techinical support team. They are communicating this issue with development team.

Can you do the same so that if multiple persons are escalating issue then they will look in to it?

Thanks.

I reported this to WD level II support months ago. I provided significant time and data for them to pass to engineering.  They never had any solutions and in the end, they traded my My Cloud for a My Cloud Mirror and the USB problem went away.  I also could never get a Safepoint to work. With the Mirror, I have RAID 1 automatic backup to the second internal drive and also backup schedules to my external My Book.

Hello all, 

We have passed this along to support.

Kiran_Nevaskar, 

I’ve encountered this problem well over a year ago and WD has never updated their firmware to fix this problem. At that time I had already discover a workaround and it really does involve SSH’ing into the device to fix it. DO NOT swap your brand new drive with a refurbish replacement drive as the same problem will occur; go figure if it is the same firmware.

WD called me regarding this problem and had me reboot my device multiple times, soft reset my devices and even made me update the firmware to my USB drive;

Soft resets and firmware updates are not the solution to this problem. The problem is an Operating System process lock that somehow one process is locking out the other; it could be as simple as the scans, or a process that is waiting for another process to complete but the process lock is so complete that both devices drops out of the network shortly after locking.  They have not resolved this problem in any of their firmware as I’ve been watching this same problem over and over on this forum.

I’ll post up a link to my post shortly,  but I’ll give you a summary the short version first.

Workaround without SSH (should work provided that your cloud is not locked in scans).

  1.  Boot up the Cloud drive first WITHOUT any USB drive attach. (Always detach the USB when rebooting especially when you do a firmware update).

  2. wait for a few minutes for your cloud drive to settle. Now this might be difficult since the scanning process will begin and start thrashing your drive but if you don’t SSH into the drive to kill the scan process, this is the way it is and forever will remain so. 

  3. when it is quiet (around 5 minutes) attach the USB drive. It should attach and you should be able to map it without problems.

Always detach the USB if you are rebooting the USB or starting it up. I made the mistake of attaching the two when booting both up at the same time when I moved the two units over to my bookshelf, they ended up locking and disappearing from the network a few minutes later.  

Alright, here is the post that fixes and solves everything back in 2014. 

My Solution to My Cloud is disconnecting from the Network and disappears when connecting USB hdd

Hi Ralphael,

I read your post but I’m confused. Are you saying that the solution is to run the following commands:

etc/init.d/nfs-kernel-server stop

/etc/init.d/nfs-common stop

/etc/init.d/upnp_nas stop

/etc/init.d/mDNSResponder stop

/etc/init.d/wdphotodbmergerd stop

/etc/init.d/wdmcserverd stop

then:

/etc/init.d/wdnotifierd stop

/etc/init.d/wddispatcherd stop

/etc/init.d/wdnotifierd start

/etc/init.d/wddispatcherd start

Is that right?

You don’t explain the purpose of stopping “nfs-kernel-server”, “nfs-common”, “upnp_nas” and “mDNSResponder”. Do I still need to run these first four commands to fix the USB issue? 

Ahh, I remember those first days fondly as I willy-nilly killed all the processes that I thought were high on cpu :stuck_out_tongue:

All the processes can be stopped in any order and you don’t need to stop the nfs-kernel-server or nfs-common. I was stopping as many processes as I can back then to get the device to sleep.

Final Fix

Anyways it always boils back down to 

/etc/init.d/wdphotodbmergerd stop

/etc/init.d/wdmcserverd stop

and detaching the USB drive before reboot and attaching it after the Cloud boots up.

i have had problem with USB drive hangs on copy functions caused by overly long pathnames…the only symptom is a hang with no error message

I also has this issue. Not sure what is the fix. When ever I connect my USB for backup NAS hangs and no errors…

i discovered my hang problem may have been caused by long filenames in
which the aggregated length of share/directory/subdirectory/filename
exceeded a system amount

i discovered this, when in frustration, i did a volume copy over the
network from a Windows system which gave me explicit error message(s)
rather than simply hanging & spinning

1 Like