WD My Cloud + Google Wifi = Unavailable IP address = :-(

Hello, Good afternoon, and Happy New Year to everyone!

I have the WD My cloud, single bay, 4TB. Which I am attempting to use with the new Google Wifi mesh network. The My cloud does not seem to be able to establish an IP range within the Google Wifi’s readable range. Google requires the device to be 192.168.86.###. I’ve tried doing it through the mycloud site and I receive the following error, “The IP address input is the broadcast address for the set subnet mask and cannot be used. Enter a valid combination of the IP address and subnet mask.” I was only attempting to change the IP address as I do not know any of the other fields… Please help I really want to continue using this WD product. Thank you in advance for your time.

The following Google support documents may be of interest:

DHCP IP reservation

Port forwarding

IP reservation is what I failed to explain referring to the .86 part of the
IP in my post. my cloud won’t accept it.

Port forwarding, seems to require specific numbers from the manufacturer
and they have yet to reply to me. Hopefully they will reach out soon, but
thank you for trying.

What is the My Cloud Ethernet cable connected to? The Google WiFi Mesh device? What IP address is it obtaining?

If the My Cloud is connecting to a separate router and is obtaining an IP address from that router then you are running into a problem with having two DHCP servers, one for any devices that connect to the Google WiFi Mesh device and one for any device connected to the router. Chances are good you have two separate IP address ranges in use which may cause problems with devices trying to communicate between each IP address range. Generally the solution when using two routers on a local network is to disable DHCP server on one of the two routers so all network devices get the IP addresses from one location.

Directly connected to the Google mesh that is connected to the router. It
shows IP address unavailable when I look at the connected devices.

You could try performing a 40 second reset of the My Cloud then access the Google Mesh settings and reserve an IP address for the My Cloud within the Google Mesh as the link above indicates. If the My Cloud is set to obtain its IP address automatically it should use what ever IP address that the Google Mess assigns to it.


1 Like

Thank you Bennor!

After the reset I used the new IP address in my browser and just had to setup all the login stuff again. Thank you so much!

I am having issues with this same thing. Idk what the problem is.

I am connecting my WD MyCloud to one of my google WiFi access points. I already have the LAN port on the google WiFi that’s connected to the modem slotted to something else.

My WD MyCloud keeps just giving me a flashing red light. I am confused at the above conversation since I do not even see the MyCloud connected to my WiFi to reserve an IP for it or port access.

Please help.

1 Like

I’m having the same issue. It seems the WD Mycloud doesn’t work with google wifi at all. Does it HAVE to be on the same access point in the Google WiFi as the modem is connected?

Sorry, I spoke too soon, a reset fixed the issue.