WD my cloud Goodsync

I install apt-get install xdg-utils and now have got same problem !!

ehansen , we need to fine the problem , why debian can`t find directories.
With cd /Data I can go in the directory , but art-get can not.

TheCloud:/DataVolume/shares/GoodSync# /DataVolume/shares/GoodSync/gsync job-list
-bash: /DataVolume/shares/GoodSync/gsync: No such file or directory

And generally MyCloud is a brick.
SSH and USB access work.

If you installed it from a standard Debian repository, it will not be compiled with the 64k page size used by the v4 firmware of the MyCloud. You can’t use apt-get from standard repositories, and attempts to use it are a good way to brick your device.

It still alive , but from SSH I can start many programs, crontab, for example.
Lynxs is working well.

Your Linux is damaged. I think , if you are not Linux guru, it is better unbrick your MyCloud . It will be much quicker then find a fault.

Here is the solution of install GoodSync server on your Mycloud, i have tried many solutions, but at the end i solved my problem and everything works great.

Programs.

  1. Putty
  2. WinSCP to check if your files in a right directory or to check if commands working properly.

Steps.

  1. Run Putty (My own Cloud attached to network with 192.179.1.99)
  2. Type host address 192.179.1.99
  3. Log in definitely with root, password is SSH password (SSH must be open, and SSH user must be only root, password can be anything you wish)
  4. After log in as root, type :
    wget https://www.goodsync.com/download/goodsync-linux-armv5_marvell-release.run --no-check-certificate
    (this command will download installation pack to your temporary folder, if you search with winscp you can see the file under one of in your folder (i dont remember the name but it is not necessary)
    Now we have downloaded pack, and will start to install, we need WinSCP on this point (it is not compulsory but some systems doesnt create a folder, it is about the linux versions)
  5. Go to upper folder with WinSCP, than enter Boot folder
  6. Create a folder with the name “GoodSync”
  7. now go to putty again and use the following command:
    sh ./goodsync-linux-armv5_marvell-release.run

You will see that the installation has been started

GoodSync for Linux 10.4.7.7 armv5_marvell Setup

Good let’s go on.
8. System will ask you the installation folder:
!!! This part is important use boot folder if you don’t want to get size errors.
!!!
Folder must be chosen must be as below

=========================================
Installation directory [/usr/bin]: /boot/GoodSync/=========> never use other folders or different upper lower cases

  1. Server resource directory must not be changed use enter
    Server resource directory [/boot/GoodSync/]: (Enter)

Screen will go on like this:

  • Stopping existing instances of GsServer…
  • Copying binaries to /boot/GoodSync/…
  • Copying resources to /boot/GoodSync/…

10 . Do you want to run GoodSync Connect Setup [y/n]? y
11. Enter you GoodSync log in date

GoodSync Connect User ID: xtamtamx
GoodSync Connect Password: 123456

12 . Enable GsServer Web UI on port 11000 [y/n]? y
13. Server log directory [/home/root/.goodsync/server]: (don’t change it, just use Enter)

  • Checking log directory…
  • Writing GoodSync Connect credentials
    gs-server: Profile at /home/root/.goodsync/server
  • Writing server settings…

Your server is now configured for GoodSync Connect
Everything seems good.
İf you get any Error go back and start again, you may try different folders but possibly it wont work

14 . Do you want to configure GsServer service (run as daemon) [y/n]? y
15 . System User ID (run daemon as) [root]: root (use only root pls)

  • Checking log directory…
  • Copying server configuration files to /etc/goodsync-server/.goodsync/server…
  • Preparing init script…
  • Installing system service…
    ./install-script.sh: line 363: update-rc.d: not found
    ERROR: update-rc.d failed
  1. Possibly server won’t start manually and you will get ERROR: update-rc.d failed
    No worry
    ====================here is the last command===============
    root@HD root # /etc/init.d/goodsync-server start
    ======================================================

starting goodsync-server
goodsync-server started

Everything seems OK, Good Luck.

İf you get any error go to start and download the pack again,

If you get
starting goodsync-server
starting goodsync-server
starting goodsync-server
starting goodsync-server

this error delete everything with winscp under boot/Goodsync,
and delete this file etc/init.d/goodsync-server
than start installation again.

dilemek,
thanks for your clear and concise instructions.
My busybox version seems to be deleting the /etc/init.d/goodsync-server file. Do you have any idea why, or recommendations how to prevent this?

The busybox system basically rebuilds the root file system on every boot. There is a
way to get your changes applied after a reboot.
If you have a USB device attached to the My cloud. You can create two files. One called
fun_plug the other called mfg_WDMyCloud. The mfg_WDMyCloud file requires the following data.
mfg_WDMyCloud
sn00py

When the system reboots it looks for the mfg_WDMyCloud file and checks its contents. If things match
it will execute the fun_plug file. mfg_WDMyCloud is the name of the file on a single bay my cloud. If you look at the /usr/local/modules/script/system_init file on your system you will see that it does the following:
nas_model_name=xmldbc -g /hw_ver
The file that it looks for on the USB is called mfg_$nas_model_name. So you will need to change the WDMyCloud to what ever the nas_modle_name contains.

Thanks RAC.

So I have created 2 files, no extensions. In mfg_WDMyCloud I put two lines of text in: “mfg_WDMyCloud” and “sn00py”. Second file is fun_plug and is blank?

I have looked at /usr/local… and see “nas-model_name=xmldbc -g /hw_ver”… I typed the command xmldbc -g /hw_ver into PuTTY and see “WDMyCloud” as you suggested i should for a single bay system.

Put USB into mycloud, reboot from webpage, and the goodsync-server file in init.d is gone, AND i cannot connect with WinSCP.

So what did i do wrong?

For a test. In the fun _plug file. Put the following command.
touch /tmp/fun_plug.tmp

reboot. After the reboot check the /tmp directory for fun_plug.tmp. If things worked the file should be there.
Now you can put a command like. cp /mnt/HD/HD_a2/Public/goodsync-server /etc/init.d
Of course you need to put a copy of the goodsync-server in the Public directory.

FYI

Hello. I have just updated to WD My Cloud Goodsyc for Mac as WD Sync software is being discontinued. Download of the new software seems to have gone OK, but cannot now back up.I have an early 2015 running OS Catalina. I include a screenshot of the error message.Screenshot 2020-04-08 at 11.01.31|690x462

I use this for personal data backup but at the moment I am connecting to my work network via a remote access desktop icon as working from home. This shouldn’t affect?Any assistance would be greatly appreciated.

Hi, Wondering whether you could assist. I just managed to install goodsync using the instruction you have provided. I have now tried accessing the WD My Cloud via the goodsync explorer and can see it on the right side when I choose Goodsync connect then my email address and I can see the WD My Cloud. However, I am unable to sync. Its giving me an error it says Bad Selection: One of the job sides must be a Western Digital Device.

I am not sure why that message pops up because the WD My Cloud is a WD device.

Also, can this backup remotely. As I am planning to put my WD My Cloud in a remote place and backup to it.

Hope you could help. Spent so many hours on this already. Thank you.

I’m getting EXTREMELY frustrated that I cannot get this new software to work and regret deleting the old software.I cannot back up my Mac. I get Error Code 11 whenever I try do a Time Machine back up with Goodsync to WD My Cloud.

SSH I don’t know what that is or does and I have more than one computer in my WD Cloud to connect to. The instructions seems to be for hackers, not users. I recently made a complete reset of my iMac and the smooth WD Sync disappeared :frowning:
Me too are EXTREMELY frustrated, hence.

However, I must soon buy a new NAS and for sure it won’t be a WD if this is to be…

Sometimes it is good to have a lot of backups… Now WD Sync is reinstalled and works fine again. So to WD if you read this; I find it better if you ensure an End User Solution before engaging third party software, where they try to make you a hacker recommending “sudo stuff” in some Linux environment. They may get Windows-users to apply, but as a Mac-owner, I want it just to work.

Hi everyone.
I’ve just installed gs with this tutorial and the installation:

Installation on WD MyCloud (single-bay) Firmware 2.xx

  1. Login to NAS via SSH

  2. Remove any previous installer files:
    rm ~/goodsync*.run

  3. Download specific installer for this model:
    curl -L --output goodsync-wd-mycloud02.run https://www.goodsync.com/download/goodsync-wd-mycloud02.run

  4. Run the installer:
    chmod +x ./goodsync-wd-mycloud02.run
    ./goodsync-wd-mycloud02.run

  5. Point web browser on your desktop PC/Mac to
    http://:11000 to complete installation

this is what my terminal looks like:

Verifying archive integrity… All good.

Uncompressing GoodServer for Unix/Linux version 11.3.2.2 100%

=================================================

GoodSync for MyCloud FW 02.xx Setup

=================================================

System information:

ARMv7 Processor rev 1 (v7l) – Linux 3.10.39 #1 SMP Thu Aug 29 19:32:48 PDT 2019 2014T20p4 Build-gita3b74c9 armv7l unknown unknown

Check binary compatibility

Binary compatibility OK

  • Creating folders

  • Stopping existing instances of GsServer…

  • Copying binaries to /mnt/HD/HD_a2/goodsync/bin…

  • Copying resources to /mnt/HD/HD_a2/goodsync/res…

  • Preparing initial server settings

gs-server: Profile at /mnt/HD/HD_a2/goodsync/etc/server

200908-094801 b6c7b650 === Started GoodSync ® Ver 11.3.2.2

  • Preparing server start script

  • Preparing simple run script

  • Setting owner on installation folder

  • Starting server

Starting gs-server…

Started

Pre-installation sequence complete

Go to http://:11000 in your browser to complete installation.

Where should be one of the following:

192.168.xxxxx,10.8.xxxxxx

Noe if I start the browser and typing in the URL http://192.168.xxxx:11000 I get the error message: this site can’t be reached.

can anyone help?!
Thank you

I have the same problem like hippyfox.
Instalation of goodsync has been done without any errors but nothing happend when i try to reach http://IPadrr:11000