Wd My Cloud fails to start

Hello people,

I hope you can help me.

Yesterday I tried to install unrar with ssh by following the instructions in the following link: http://community.wd.com/t5/WD-My-Cloud/SABnzb-quot-No-UNRAR-program-found-unpacking-RAR-files-is-not/td-p/668759

But at the end it gave an error message that some dependences might not be installed and it seems that some service could not be restarted.

Now the LED device is blank, I can not access it, nor by ssh or ssh the device is not accessible via the network I would like to know if there is how to reset the device and debian from scratch, system reset button or a way for the operating system running again.

Thanks for your help, I have important information and do not want to lose it.

I forgot, I did the reset for 40 seconds but I get the same result. :confounded:

Hi, same pb for me !!! :frowning:

Please clarify what LED device is blank means? If it has power the front LED should be red, white or blue.

what are the LEDs by the Ethernet port doing?

what FW version are you on? V4 has a non-standard pagesize and presents issues in adding programs

can you ping the mycloud? SSH to it?


same problem with mine. Sometimes my LED is blue but i can not access the Dashboard ping is possible but no ssh connect. After some time my LED turns red. Hard reset seems not to work.

any chance the drive is getting too hot? that would explain red LED after awhile

have you tried a system only restore?

Hi, thanks for your replies

The unit was dead, I used these guides:



I think when I install from agt-get the unit installed some wrong packages, if you see some guides for install new packages like rar 5 or other, you do not change the list and apt-get update or apt-get install.

Now my unit is alive again, but in the web gui the empty space is wrong and the access to the public shares doesnt show in smb.

Can you help to fix 2 issues ??

Thanks in advance.

Not sure how to get the empty space right.

But to correct share problems you definitly want to check the file /etc/sambe/overall_share. It is being included by the samba config file /etc/samba/smb.conf, and defines all the shares on the mycloud and the read/write access.

I ran into a problem where this file was blank (zero bytes), and I had to edit it by hand to reflect the shares I have in the gui.

Theoretically gui and /etc/samba/overall_share should be the same, but I have experienced the differences first hand. So make sure the file contains a paragraph for every share you have on the mycloud.