WD My Cloud drops remote connection

Worked good until latest firmware upgrade (I Think). But now I loose Connection from external pc Win 10 all the time. I turn off/on the Cloud Connection and it works for some hours and then drops the Connection again… anyone have a solution?
I have DHCP setted on WD My Cloud and the router…
What is the best way to set up for stabil Connection??

What router do you have? Are you able to reserve the address for your My Cloud on your router? If not have you given it a static address?

Hi. Thanks for rapid answer. I have a Huawei router. Have not reserved or given any static address. I can reserve or set up at the best way… Please give me the best option. I am not at the Place of the router right now so I do not have information of the exactly model.
Gracias

If you do not have a User Manual for your router you can do a search using your favorite search engine and find more information on it. You can try out this link, https://www.google.com/search?q=huawei+router+setup&ie=&oe=#q=huawei+router+setup+manual .

Below is an example image showing my router and how I set up my reserve address for my My Cloud.

Click on, tap or activate image to enlarge it.

Hi again Cat0w, thanks. One more question… shall I let the WD My Cloud still be setted as DHCP??

If you are able to reserve the addresses that should work without any problems.

You wrote “addresses” isn’t it just one IP I shall reserve for the WD in the router? Shall I reserve it against a Mac address or something on the WD??
Sorry for the questions… just wanna make sure I’m doin this correct now.

Hi… just came home and checked the router… I had reserved a IP address in the span of the router to the mac address of the WD My Cloud device. Are there more settings to do?
Some port settings or else??

Gracias

I was probably thinking about mine when I said addresses because I have done it for almost every thing I have connected.

Ok… then I will see… because I had already locked an IP to the WD. But I restarted all units and saved settings again. New day tomorrow…
Thanks for conserning

I will be interested to know if your issue was resolved, I have the same issue but in my case I don’t think it is about not having a static IP. I actually don’t have a static IP but I can ping the device with no problem.

More details:
It all worked fine for many months and last week as I tried to create a new user and then a new share. As soon as I got out of the shared folders section and got back, the newly shared folder disappeared. Tried that 3 times. so I power cycled the MyCloud and that worked fine. Then going through the settings I disabled the sleep mode.
A few hours later it was not accessible from my PC nor my Phone APP although I was able to ping it.

I power cycled it and after an integrity check it was back online. I figured disabling the sleep mode was the cause so I enabled it but a few hours later and again was able to ping but not accessible. For the past week, every day when I need to get some data from it I need to power cycle to access it for a few hours.(not sure on how many hours it works)

Hi Michel, since relocking the IP in the router to the mac-address of the WD MyCloud, it still connects remotely after about 18 hours. I also did a restart of both the WD and the router…
But you never knows… I must have it running a Little longer to tell it works. :slight_smile:

Thanks for the quick response Thomas,

I was not so lucky yet.
Shortly after my first post, I gave the WD a static IP, rebooted my router, switch and computer, it’s been about 1 hour and the WD is no longer accessible.

Hi Michel… sure you set the WD to DHCP and just a locked IP in the router?

Hi again… was hoping for to much. Today when arriving to work 7 km away…DROPPED Connection. Can,t go home just to restart cloud Connection in WD unit :frowning:
This is bad. From home where the WD is physical connected works good. The locked ip is the same. Was remotely connectable for 36 hours.
Must be a bug… someone knows…?

Contacted my wife at home… told her to do a hard restart of the WD My Cloud iow disconnect the Power Cable for 20 sec and connect again.
Now the remote Connection works again… but shall I live with this… restart the WD every 36 hour??
Have no clue why it dropps the Connection. Can it be something related to the update with the www.mycloud.com??

Hi Thomas
I cleared some files from my WD and it started working fine again. It it the 2TB model and I now have 300GB free. I realized I started having this issue after uploading the backup of a customer’s computer which loaded it up to 100GB free.
This is something mysterious and I am not sure I made a good choice by buying this product.
Hope this helps.

Hi Michel
Thanks for information. I have the 4tb model with a 1tb usb disc connected. Not near the limit… have about 3.2 tb free.
But now it worked for 3 days… shall check again on monday at work…
I am also a little skeptic to this unit. Been a lot of trouble…

Now drops the Connection again…after about 2-3 hours running and then drops!!! I’m getting real irritated now. Some one know how to get a reliable Connection to the WD MY Cloud remotely.
Works inside the router…