WD My Cloud doesn't show up in "Browse for Folder"

Hello,

I’m trying to set up a program that will copy files from a source path(my hard drive) to a destination path(WD My Cloud). To set WD My Cloud as the destination path, the program has me look for it using the “Browse for Folder” dialog box.

The problem is that when I browse to Network(or anywhere else) to select my WD, the drive does not appear.

The drive does appear under Network in Windows Explorer, just not in the Browse for Folder box. I’ve tried setting my WD as a mapped network drive and as a network location, but neither of these cause my WD to become visible.

Because my WD isn’t visible in Browse for Folder, I can’t select my WD as a destination. :frowning:

I’ve been googling about network drives not showing up in Browse for Folder, but I can’t seem to figure out a solution.

Does anyone hear know how to fix this?

I’m using Windows 8.1 and my WD is connected to my router.

Thanks all!

What is the program you are trying to use? Are you sure it supports network folders/drives?

Hi Etupes,

The program is called XBMC Media Move and is meant to move and sort downloaded files.

I can’t be sure if it supports network folders/drives, I just assumed it would. haha

However, my WD drive also does not appear when using the Browse for Folder box that appears when mapping a network drive in Windows 8.1… I had to manually enter the location of my network drive/folder to map it.

… Unfortunately XBMC Media Move does not allow me to enter the destination path manually. :frowning:

Could it be that file sharing or SSDP discovery services are off on your computer?

I just checked and SSDP is running.

You know what, up until now I’ve never noticed that my WDMC drive only shows up under Network when in Windows Explorer. I’ve only been storing media on my WDMC drive and until this point was always dragging media from my HDD via one Windows Explorer window to my WDMC drive via another Windows Explorer window.

It wasn’t until trying to set up an app to automate the above that I’ve now just noticed that my WDMC drive never shows up under Network in other programs… such as their Save and Open dialog boxes etc.

Is that normal?.. That a WDMC drive only shows up under Network in Windows Explorer only??

Actually, even under Network in Windows Explorer, the WDMC doesn’t behave like a normal drive. It shows a picture of the WDMC drive labeled “WDMyCloud”, but when you double-click it it opens the drive’s controls panel. Normally double-clicking a drive opens the contents of that drive by default. Is this the normal behaviour for a WDMC drive?

I forgot about the behaviour of the WDMC drive under Network(storage) in Windows Explorer because I set up shortcuts to the drive’s IP when I first got the drive and have been using those shortcuts to open the drive contents ever since.

To see if it would help the drive show up, earlier today I mapped one of it’s main directories(shares) as a drive. It shows up(under “Network locations”) along with other drives in some applications, but not all. Even if it did show up in all applications, I don’t want to have to map each main directory just to make them visible to apps.

Shouldn’t a WDMC drive be accessible and visible in it’s entirety in all programs’ Save, Open, etc dialogs?

Thanks again for any help!

Peter

If you see an icon with WDMyCloud on it in the ThisPC window, this is not a regular “folder”. It is the DLNA media player. When you open this, you will see folders like Music, Videos, Photos, and the content is the corresponding media files that the DLNA server built into the NAS has foun don your NAS.

You will see a *device" in the network window, and when you click on this, you will get sent to the home page of that device. Same thing with a network printer, etc.

What you should see in the network window is a *computer" that is sharing “shares” when you double click on it. Shares have a folder-like icon connected to  a “pipe” below. You should see at least the Public share there. Do you see it?

I just disabled the DLNA server so the only WD My Cloud icon I have now is this one and it’s the only place my WDMC drive shows up under Network anywhere on my PC…

wdmycloud_network.png

If I double-click the computer(Peter-Work-PC) under network, the only shared item is a “Users” folder…

  computer_shared_network.png

I tried changing a Movies folder/share on my WDMC drive to “Public Access” and rebooted my comp and it still doesn’t show up… just the Users folder as above(and I looked for the Movies folder in there too).

You should see your a WDMyCloud network item under Network, and at the top of the network window, just like you see PETER-WORK-PC.

Did you try to reboot your NAS?

is the PC and mycloud in the same workgroup?

Hi Larry. Both appear to be in the same workgroup “WORKGROUP”.

workgroup_name.png

I tried rebooting my NAS and then my comp, but nothing.

I did notice that the IP address for the WD drive showed up under Network on the left when I browsed into one of its directories using a link/shortcut.

So in the first window, I used a link/shortcut to navigate into the root of the drive where all my shares are listed. However the IP address doesn’t show under Network.

But in the second window, if I go into one of the shared folders the drive IP then appears under Network.

However, as you can see in the third window, the drive only shows up on the left under Network and not on the right with other network devices… well, not like you say it should anyway. It still has the icon under storage but that doesn’t show up anywhere else on the PC other than in Windows Explorer.

Also, once navigating away from the drive, as soon as the folder tree on the left gets refreshed or Windows Explorer is restarted, the IP disappears again.