WD My Cloud disconnects from network every now and then

I know there are dozens of topics on this subject but I didn’t find a solution. Still I’m hoping there is one because this is really annoying,

I can watch a film for about 30-60 minutes, then I get the message ‘network connection loss’. It will reconnect after a few minutes but then it disconnects again and more frequently, I would say every 5 minutes.

This is what I tried;
Reboot NAS
Assign a fixed IP to my NAS in my router settings.(also done on the NAS in dashboard/settings)
Switch off ‘cloud access’
Turn off automatic upload of photo’s in the Cloud App (ios)

Nothing seems to help

Does anyone know how to solve this problem? It’s impossible to watch a film like this…

Are you viewing the movie across the local network or through a remote connection?
Are you using WiFi or Ethernet for the device that is having trouble playing the media?
What program, software or app are you using to view the media file?
Have you tried using a different media player?
Do other computer’s or mobile devices exhibit the same problem?
Have you tried rebuilding the DLNA media database through the My Cloud Dashboard > Settings section?
Have you checked the router logs to see if it is the cause of the network drops?

I’m viewing through a local network, WDMC is connected via ethernet cable, my Samsung TV is connected through wifi. I’m using a TP-link router and the network is stable, TV and WDMC have static ip’s.
I installed Plex Server on the WDMC and with an Plex app on my TV the two are connected so I can play my media. The TV can also browse the WDMC without using Plex and stream media but both of these viewing options have the same ‘network connection loss’ problem from time to time.

I haven’t tried another viewing device/software long enough to be able to say that the same disconnecting problem occurs. Neither have I tried to rebuild the DLNA media database, so I have to try these things and let you know. Thanks for these suggestions.

Something worth mentioning; the above setup has worked for 2 weeks without any problems, a few days ago the ‘network connection loss’ problem started.

Try another device to stream the media and see if it has the same problem. If you do a search of this subforum, using the magnifying glass icon upper right, for Samsung TV you’ll find a number of threads where people had problems with Samsung TV’s and the My Cloud. There may be additional suggestions or workarounds discussed in those other threads.

How? Plex isn’t supported on the single-bay MyCloud, which is the subject of this subforum.

Have you used a wifi analyser? it may be that another wifi system has appeared recently, causing problems for your network.


Officially you can’t install plex on a single bay. Unofficlially you can!

You could be right actually that another wifi system appeared, I got new neighbours this week.
So what to do then?

I know it can be installed. But there’s a good reason Plex don’t produce a build for the basic MyCloud, I think…

Plex want as many people as possible to use Plex, buying client licences. If the Plex server worked reliably on the basic MyCloud, don’t you think they’d release a build for it?

Well, according to fox_exe the processor of the WDMC is similar (or even slightly better) to the ones that officially do support Plex.

I just took the risk and installed the crack version, it works beautifully apart from the disconnecting problem that I have recently. Can’t imagine that this is a capability problem though…

BTW, it’s not Plex who ultimately decides that their software can be installed on devices like WDMC. It’s WD who makes this decision I guess. If Plex could be installed on the cheapest WD NAS there wouldn’t be a big market for the expensive ones,

First, Plex is not officially supported on the single bay My Cloud units. By installing the unofficial version of Plex for either the v4.x or newer v2.x single bay My Cloud units one is potentially modifying the My Cloud firmware and operating system. Such modifications may introduce instability into the My Cloud leading to playback issues either using Plex media server or even the My Cloud embedded Twonky media server.

More information about what NAS units are officially supported by Plex one can see the following Plex links.
NAS Devices and Limitations: https://support.plex.tv/hc/en-us/articles/201373823-NAS-Devices-and-Limitations
Plex NAS Compatibility List: https://docs.google.com/a/plexapp.com/spreadsheets/d/1MfYoJkiwSqCXg8cm5-Ac4oOLPRtCkgUxU0jdj3tmMPc/

For many of the My Cloud units that are supported by Plex the Plex compatibility list indicates the following; “Transcoding is not supported on ARMv7 only remuxing”.

Additionally running two DLNA servers at the same time on the My Cloud may introduce instability when streaming to DLNA clients.

In any event one needs to isolate where the problem lies. If only one PC/device exhibits the disconnecting then its probably a problem with that one PC/device or how the DLNA server views that DLNA client. Any time one streams over WiFi there is always the possibility of streaming issues. If possible try to isolate the issue by using Ethernet to test rather than WiFi.

Yeah, it’s possible there’s some commercial agreement between WD and Plex to assist WD’s vertical marketing strategy.

The new neighbours, and the wireless devices they have sounds a possible cause of your issues. You may be able to find a quiet channel, and instruct your router to use it, but it really ought to find it itself. If not, then you’re simply finding one of the limitations of WiFi… A WiFi analyser app should be able to show you your wireless environment. I have one on my Android devices, and my router has one built in.

I appreciate you saying this, so it could be that installing Plex the unofficial way is causing instability, and therefore the disconnecting problem.
However, how does Plex work on the more advanced WD devices then? You would have 2 dlna servers running simultaneously as well, or not? Is there a way of disabling one dlna server BTW?

For now I connected my TV with ethernet cable to my router. Let’s see if this makes a change, after that I will also try to stream from another device.

I’ll let you know

Surprisingly, since I connected my TV with an ehernet cable to my router I had no ‘disconnecting errors’ anymore! Watched about 6-7 films (>8 hours), everything seems stable. So problem solved I guess, thanks to Bennor and cpt_paranoia!

Something else worth mentioning;

All I can say is that my ‘unofficial Plex install’ runs fine! When watching a film, dashboard tells me; temperature normal 36 °C, CPU under 10%, RAM 61.15% (512MB installed).

I’ve got a film library of nearly 1TB, most of it plays without any problems (i would say over 90%).
The problem lays with some older formats (like MPEG) and when I add subtitles (srt) to the film.
In both cases Plex will give the error ‘This server is not powerful enough to convert video’.

For me not such a problem as there is an easy workaround; just put the film on USB stick and play directly from TV. Films that are downloaded MP4, MKV, AVI, DiVX format, I had no problems with so far…

Good to hear you have a workaround. It may be possible to sort out the WiFi problems.

Also interesting to hear your Plex experience. I’m happy running Kodi for video and DLNA for audio, so I probably won’t be installing it (or paying for the client app).

I have had wired connection all the time. Here is the solution that helped to me Video streaming stops after 20 -30 minutes