WD My Cloud device completely broken (help!)


#1

Hi all,

I have a WD My Cloud that I purchased about 3 years ago. This is the previous Gen model, 3 TB.

I had it plugged in directly to my Wi-Fi router which I then used to stream to my TV, as well as access files via my computer. I use a mac computer and mainly used it via a Macbook.

I went on holiday for a few days and when I came back it stopped working - yellowish light. I literally tried everything, used the reset pin option at the back for a few seconds, and then used the reset pin option shut down method (you switch it off and hold the pin in for a minute whilst switching it on). Nothing works.

I then plugged it in directly via network cable into my laptop and had a close inspection. The blue light never comes on, only the yellow light remains. I then checked network port at the back and noticed the lights go on for a few seconds and then go off completely. I even left it plugged in for an hour and no change - it does not get picked up on my network drives on my computer at all - its like it doesn’t exist.

I have virtually tried everything I can think of - any more suggestions, let me know.

Next step, I would like to try and recover the data somehow. I used a two-sided USB cable and plugged it into my laptop (foolish I know) but it doesn’t pick it up as as drive as I am sure the port is only for extended hard drives.

I live in South Africa and there is virtually ZERO support for WD this side of the world, even in terms of data recovery support. I called various large and small computer repair companies and can’t find anyone that can assist me.

Is there any possible fix that I have not yet thought of, if not, how on earth can I hopefully recover my data? If i literally break the device option (doesn’t seem to be any visible screws to open) is there a generic hard drive that I can extract and hopefully connect to save my data?

That being said, what I have realised is that its probably better to get devices that have external hard drive slots - that way, if the device breaks, you can at least extract the hard drives and retain your data. Furthermore, the support level experienced by WD is poor - this is probably the last time I will ever buy a WD device.


#2

Have you tried using a different Ethernet network cable to connect the My Cloud to the router?

Try a 40 second reset. See the following Knowledgebase article for how to perform a 40 second reset.

The My Cloud USB port is only for attaching external USB hard drives, it does not support being connected to another computer like one would for an external USB hard drive.

Can you access the My Cloud Dashboard?

Is the network router assigning or showing an IP address for the My Cloud?

If you previously enabled SSH through the My Cloud Dashboard, can you access the My Cloud using SSH?

See the My Cloud User Manual (https://support.wdc.com/product.aspx?ID=904) for what each LED light color indicates.

One extreme option is to remove the My Cloud hard drive from the enclosure and see if the drive is accessible. If the drive is not corrupted one could try “unbricking” the drive. Use the forum search feature, magnifying glass icon upper right, to find past discussions on how to unbrick a My Cloud.


#3

Yes:

You can find instructions on how to dismantle the case on YouTube. There are two tabs on each side of the rear case. Slide shims (e.g. old credit cards) into the gap, about 10mm deep, and slide the case cover forwards.

It sounds like the NIC has died. It wouldn’t be the first.


#4

Thanks for the help. I’ve tried a different network cable and have also tried all the various reset options.

I cannot see the device on my computer at all.

What is SSH and how do I use that?


#5

Thanks - will explore one or two more things but will eventually call it a day, use the Youtube tutorial and see if I can at least recover my data.


#6

Have you try solutions described in this topic ?

Click on the primary file archive, then mycloud / gen 1…