WD My Cloud Desktop app on Mac Error: "No WD devices found in your network"


An annoying Error that I wonder if others get as well? (Found no mention in the threads)

When I start WD My Cloud Desktop app on Mac (ver I get the Error message “No WD devices found in your network”

Clicking “OK” a number of times and the dark blue backgorund goes transparent and eventually i can see the folder tree and use the app.

If I leave the WD My Cloud Desktop app idle for a while the error appears and I have to click the OK button a number of times to use the app again.

It’s a rather annoying bug. It appears on both my mac - both on Maverick. I’ve done the uninstall / reinstall routine with no success and not sure what to do next?

Annyone who experiences the same problem and perhaps have a solution?

Best wishes .petter


Just out of curiosity… Do you still get this error if you turn off the sleep timer on the MC?

Have you tried to reboot your My Cloud device?  That solved a similar error for me.

I have the same problem wih my MAcbook Pro but not with my Mac Mini on the same network. Really hope to find a solution fast. Can’t seem to stream movies either through the desktop app and I’m guessing this is the reason as it works on the mac mini and iphone


I have the same exact issue. I have been on the phone with Tech Support for the last two days and they cannot figure out what the issue is. I got to a Tier 2 level tech person who exhausted every option WD has he came up with nothing. Basically at the end of the call he had me generate a System Log from my Mac and also a Device log from the drive and email it to them to have them examine what the issue is. I also cannot get WD2Go.com to show any of my folders or files either, only in Firefox will it work.

He claimed I was the first one to have this issue that support was aware of but I really can’t believe that. 

Current System

iMac with OSX 10.9.1

My Cloud 3TB

My Cloud App ver 1.03

My Cloud is connected to Airport Express which is wirelessly connected to Airport Extreme. 

I have tried connecting directly to the Airport Extreme and it gives me the same results. 

I have the exact same issue along with others on the 3 TB.  Currently I can see the drive in my finder and go to my public folder but when I try to enter my music folder, nothing.  I can see the contents of the Video folder.  

I see my music in itunes under Shared.  

Bizarrely, after reading this thread, I tried clicking over and over and it incrementally lightened up until tadah!  it opened.  Very laggy though and really not very functional.  

After having this drive almost a month, I have to say I’m extremely unhappy.  I even had my router upgraded to the specifications given and the functionality is not as promised, speed is not as promised, basically nothing is as promised.  

And while typing this comment, the “No WD Devices found in your network.” notice reappeared.  

Just really amazed that WD has released something that functions so poorly.  

exactly the same issue as I have. It is definitely not plug and play as promised and like you I have been underhwlemed by the lack of interest their support people have.

I am amazed that this issue I share with has not been properly addressed by any WD technicians/engineers!

Bought and installed a 2TB WD My Cloud almost 2 weeks and have had the exact same problem when accessing it from my MacBook Pro running 10.9 Mavericks. I have tried all troubleshooting possible and still this problem exists. I tried contacting WD technical support who was completely ignorant to the problem and didn’t even know what I was talking about. It was very apparent to both myself and the person I was speaking to that my knowledge of computers and technical trouble shooting with this product far surpassed his, which was pathetic to say the least. 

You are not alone in experiencing this problem, and until WD actually gets someone with knowledge of their product investgiating this, I doubt it will ever be fixed. 

Needless to say, the lack of support makes me a bit apprehensive that all it it may take is some type of update from apple to lose all compatibility with this system. If that happens, lets just hope that it is within my warranty period.

Just bought My Cloud 4TB and the same error.

WD Support! Please update your Software for MAC OS.