WD My Cloud App uploading partial images/photos

I’m trying to upload photos from my iPad directly to my My Book Live.  For the most part, it works fine, however there are a number of photos that are being “cut off”.  Only part of the image is showing up.

At first I thought it was maybe a corruption thing going over the wireless.  I had uploaded over 200 photos, and 18 ended up partial.  But now I try to re-upload those 18, and they still show up as partial photos.

Even if I do them one at a time.

The photos look fine if I look at them in on the iPad.

Any thoughts?


I got the same problem when I uploaded photos from my iPad 3.  The partial photos looks fine with other viewer app on iPad.

Yeah, mine is too. Wonder how we fix it!!

Are y’all saying that you only see cut-off photos when using WD Photos?   or are you using the My Cloud app?

If it’s with WD Photos, try rebuilding the WD 2go database on the NAS – WD Photos does not show the original image – it shows transcoded copies.   It sounds like the transcoder munged some of them.

When I view the files and see the cut-off images, it’s through Windows Explorer and Windows Photo Manager.  I’m not using a WD app.  I’m trying to view the photos directly on my PC.

I am not using WD app either. Still no answer from WD yet ?

I have the same issue.

I see the original post of this issue was back in January… Is there a way to escalate this? This is one of the main reasons why I bought the mycloud drive… Like the original post mentioned… Only some photos are experiencing this issue… But I too have tried reuploading the same photos without success.

To be honest, I haven’t tried using it since I originally posted, and I never actually tried contacting WD support directly.  I only posted here to see if anyone else may have seen the problem and had a solution.  Apparently others have seen the problem, but no solution yet.