WD My Cloud App for iPad booted me out after launching a certain PDF file

Hello all,

 I tried out WD My Cloud App for iPad on my 32 GB iPad Air. I was able to access My Cloud device from iPad without any problems and can load, download, or view ePubs, PDFs, or CBRs.

 But just one small issue that I am having an experience with this software.

 I was not able to view some certain PDFs. When My Cloud loads up a certain PDF and getting ready to launch, I was booted out of My Cloud app back on iPad Home screen. I ever tried to download, but still same result.

 The solution I had to do was to use a freeware Remote File Manager to download a certain PDF from My Cloud and open in my favorite PDF reader.

 I would still like to use WD My Cloud app to launch all of documents. Some certain PDF files were like about 150 MB average, but I was able to view some other PDFs at that size without issue.

 Any one experienced this and know a solution?

Thanks, Tom


Have you tried uninstalling and reinstalling the App?

Yes I had done that (uninstalling and installing).