WD My Cloud app crashes on opening - Android 4.4.2

The My Cloud app 4.1.1 seemed to install ok on my LG GPad running Android 4.4.2 but every time I open the app it crashes with the only options to “Report” or “OK”

Any ideas?

Steve O

Hello and welcome to the community,

Have you tried uninstalling and reinstalling the app?

Have same problem on both my iPhone iPad, I also installed it on a friends Samsung, the app crash. 

I email WD several times, no reply, did you solve this issue?

Seagate works perfectly, it also stream on the Roku

Have you tried uninstalling and reinstalling the app?

Thanks for answering. 

Yes…twice.  Same result.  The message I get is “Unfortunately, WD My Cloud has stopped”  Options given are “Report” or “OK”

Just another weird thing, when it first tries to open and the tablet is sitting in portrait mode, it switches to landscape mode just before it crashes.  I have auto-rotate turned off.

Still no resolution to this.  Doesn’t anyone have any idea?


Steve O


I know it’s an old thread, but i’v ejust bought a new tablet (well was given it as a freebie when i took out a new phone contract, but i digress) an EE Harrier tablet, and am getting the same problem, including the landscape/portrait switching.

Did this ever get solved and if so, how???

I also have this issue, just brought a Lenovo K920 Pro running Android 4.4.2. Would really like a solution to this. 

Me too.

I have a Lenovo S930 running Android 4.4.2.

Upon attempting to start WD My Cloud app, the screen goes black (except for the Notification Area - the top bar with the notification, network, wifi and battery icons). Then the notification area alternates between landscape and potrait modes a few times despite the phone staying completely still. It does this until the screen times out.

I hope WD can come up with a solution. Really looking forward to access my NAS from my mobile.

Thank you.