WD My Cloud Android App Connection Problems


#1

For the past week I have been constantly getting the message:

User does not have permission. (403)

When I try to use the WD My Cloud android app (on a Samsung Galaxy S4 mini) using the mobile internet when I am out and about.

Connected to my home network it works just fine.

I’ve tried generating a fresh code, linking (and relinking) my device to the WD cloud, re-installing the app and swearing a lot, but nothing has worked.

I had this problem when I first got the My Cloud and it seemed to sort itself out (I didn’t do anything then that I haven’t tried now).

Grateful for any ideas as to what I’m doing wrong.


#2

Hello Fidney, welcome to the Community. Try removing the device and adding it back again. 


#3

I’ve tried removing and then adding the device in the dashboard, but that hasn’t worked. :womanembarrassed:

Tried uninstalling then reinstalling the app.

I’ve also tried clearing cache and clearing data on my phone.

I can connect when on my home network, but as soon as I’m on mobile internet connection is refused.

I’ve tried generating a new code, and I can see from the dashboard on my PC that it has been accepted and that my phone is connected, but then I get the 403 error if I try to look in any directory.


#4

Fidney I have exactly the same problem as you!  I cannot connect via the android app when I’m not on my home Wifi.  However if I use my mobile 4G connection as a portable Wifi hotspot and use my laptop to access the device it works fine, so I know there’s nothing wrong with my router settings or indeed the device itself.

Has anyone got this app working properly via a mobile network?


#5

Incidentally the WD Photos app works fine over 4G!


#6

I’ve just tried the Wdmycloud app on my wife’s phone, as her phone isn’t running Kitkat like mine (in case this is all a Kitkat problem).  Same issue - User does not have permission.  However, if I use my phone on 4G as a portable hotspot and connect my wife’s phone to it via Wifi then the app works fine!  So I then tried this in reverse (my wife’s phone on 3G and acting as a portable Wifi hotspot; my phone connected to hers via Wifi) and the app also works fine.  Aargh!  There must be some wierd fault in the app that only let’s it work on Wifi…


#7

I think I have exactly the same problem.  

Using the android app I can’t see thumbnails, and when I click on one of the jpg filenames it gives an error.

I’ve wiped the My Cloud box, and started again, and the same thing happens.  I’ve also rebuilt the databse. 

Really annoying - if I can’t see my photo library on my phone then that defeats the point of buying the box.

Also, the “Capacity” section of the home screen just displays “-”

I’ve logged a support request, let’s see if they respond.


#8

I finally fixed my access problem! It turns out I had old mobile access settings on my phone. My APN settings on O2 were “O2 Postpay GPRS” and should have been “O2 Mobile Web”. As soon as I installed the new settings I could access my files over 4G.


Android app access
#9

hi i’m havigin the same problem with s5 mini when we turn the wifi off on my wifes i phone works fine

does anyone have an answer to this problem yet


#10

i have a solve that worked for me .
i loged in to the admin on my MYBookCloud Settings| Remote access | Mobile devices | -
then i removed all the devices in my list and re added what i needed
seams to of worked


update

lol spoke to soon
worked for like 10 min

Got error 900 and 905?


#11

I have the same problem on 2 x Samsung Galaxy S5 and another Samsung mobile… tried all the above to no avail
My sons’ I-phone works OK