WD My Cloud and My Book Live drives not seen in network on Windows 10

#1

Hi

Is anyone else having this problem?

I have a 3Tb WD My Cloud, 3Tb My Book Live and a Seagate Personal Cloud 5Tb network drives, all on the same network. In Windows 10, when I look in the network section in File Explorer, under computers, it sees my other computers and it sees the Seagate drive, but not the WD drives. In the Media Devices section, it sees my other computers, my TV and all three network drives. In the Storage section, I see all three network drives, and I can access all three dashboards from the too.

I can only access the data on my WD drives through Windows 10 via the WD quickview app. My other computers have Windows 7 on them and they have no problems at all, I can access all three drives through the network no problem.

Am I the only one having this problem?

Thanks in advance for your replies.

#2

Yes others are having problems with Windows 10 and the My Cloud. See the tacked first thread at the top of the subforum called “Compilation of Windows 10 Methods, Steps and Solutions” for possible workarounds until Microsoft fixes the Samba problem they introduced with their Windows 10 November update.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#3

Thanks for the info, unfortunately none of the options outlined worked for
me, so I’ll either have to put up with it or go back to win7. Which maybe
the better idea.

#4

Did you try the “Disable SMB2 & SMB3” option? That has worked for others (including myself).

Disable SMB2 & SMB3:

  1. In the Windows 10 Search field type “cmd”.
  2. Right click on Command Prompt, select Run as Administrator.
  3. Click the “Yes” button in the “Do you want this program to make changes to your computer” dialog box.
  4. In the command window, type the following commands hitting the enter button after each line:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

Reboot the computer and check with Windows File Explorer to see the status of the My Cloud under “Computer”. It should now be listed. You may have to hit the Refresh button (or F5 key) to refresh the page.