WD My Book World Not Responding to Wireless Connection

I have a home network with a 1TB WD My Book World Edition attached with a twisted pair connection. I can still get to my drives with my wired devices (2 different workstations running XP Pro and Windows 7).

Until today in could access my drives using laptops connected wirelessly to my network running Windows 7 and Windows 10, but I now am unable to connect with any of my wireless devices. Windows 7 Diagnostics reports my laptop is configured correctly, but the device (the WD My Book) is not responding.

I have made no changes to my network configuration or router; all other wireless functions work fine (e.g. connection to the Internet).

I have tried restarting the router and the WD World Book but still cannot connect wirelessly,

Does anyone have any ideas on how to fix this?


Have you tried resetting the drive? maybe doing a power cycle? Also try connecting the drive directly to the computer using the Ethernet cable.

Thanks, that may have been the issue - it’s a pretty old drive, but a good one.

I did power cycle, but that did not seem to help. However, it suddenly began responding to my wireless devices about 4 hours later. I suspect one of the components in the device is starting to go. Looks like I’ll be stepping up to a newer model soon. Starting to research what’s best these days

Again, thanks for the response.



Harry Clark