WD My Book World Edition II External 2TB NAS Drive

My WD NAS drive not accepting DHCP address from router.   WD Discovery software cannot detect WD NAS on my network.     Reset did not correct issue.

I can assign a static I.P. address via the NAS Web interface successfully, but still the WD Discovery software does not detect the WD NAS unit.    Even with direct crossover Ethernet cable to the WD drive still no detection with Static I.P…

What to do ?

Hi, did you tried resetting the router? If the problem continues you can also try connecting the my book directly to the computer Ethernet port. 


Yes I did reset the router, and yes I did connect My Book to the computer Ethernet port as stated in my post.

The Discovery software is not recognising the MYBook on the network or directly via the computer ethernet port.


I have the same problem as VTwoodsman I have the white light version and my computer is using windows 8.  Sorry I am a noob to this, but can someone help me to make a static IP settings and how to set up the wd my book world edition NAS drive when u plug it into the ethernet port like white to do after I plug it in to the port?  Please need some help or can someone direct me to a website or page to help me with it.  Thank you 

i have the same drive iv tried using the WD discovery program and i have the same problem with it, it does not find my drive.

i have been using this drive for years though without any problems, until now when trying to use it with a smart tv