WD My Book USB Device cannot start code 10

My Western Digital USB 3 Had Drive is not available in windows 7 Professional x64. This suddenly happened after upgrading My 250 GB Samsung SSD to a 500GB SSD and I have read as many threads as it took to make me ask a question (Days of threads, and fixes, Grrr) and No Luck. I am hoping that these screen shots may help.
To Begin With, Western Digital SmartWare shows my drive perpetually “Discovering”
*Image Removed Because I am a new User and can only post 2 images The ones below seemed more informative

USB Safely Remove Devices, Shows the WD MyBook, even the “icon”

Device Manager Shows Error Code 10 device cannot start, I have uninstalled all and rebooted, the entries return. I have a USB Keyboard and mouse and have removed all other USB Devices BUT the Generic Flash HS Combo/CF keeps returning. (I Did have a USB Flash Card Reader, previously, but it is not plugged in.)

The Western Digital Drive Was Drive “G:” does not show up in DevMgmt.msc. ( I Dare not upload that image the last took forever to load, and I fear I am pushing my luck.
I have inspected the physical, (No Drive Clicks, or any sounds but drive spinning happily/quietly)
Replaced the USB 3.0 Cable that came with the Drive and tried 2 other Known Good Cables
I have run the Associated Microsoft Fixits.
I have Read MS KB Articles mostly having me Delete the USB upper and lower filter registry keys.
I am in process of posting this same problem to Microsoft, AND Samsung however I have no problems with the SSD, or USB in General, IE Other USB Devices Work.
I have a Brand New 3TB WD Drive Standing By, with multiple enclosures, and or Server Bay options standing by, but I REALLY Need the Data, this is the Second tier of my backup and because of the drive rotations It is now my primary.

Why am I thinking that a filter driver within the operating system could be at fault. I’ve had this ages ago where any USB storage would not work and I recall editing the registry as some other program ended up becoming broken.


Thank you for the reply, I am in agreement that is a possibility, specifically the USB Drivers in Windows, but next steps elude me.

The problem I recall was to do with the computer not recognising a CD drive. It turned out to be the CD writing software. Two options was to make a registry edit to remove the filter driver from the chain of them and the second was to remove the software and re-install.

I think under Windows 10 it’s called a Device Stack. An example:

When I had to deal with this I was still on Windows XP. What I do remember is that it took a bit for me to understand how this all worked. I recall as I was troubleshooting the CD drive I took each 3rd party driver out in turn until it worked. Reboots in between. The registry is something that needs to be treated with the utmost respect.

This could be what you’re experiencing. Is there anything you installed prior to the malfunction?

Thank you for the detailed reply ! I have seen a lot of questions about this issue, and have also opened tickets with Samsung, and Microsoft, and read all the threads I can, this seems to be a fundamental, and common enough flaw, I am surprised netiher of the other vendors has replied with any suggestions yet. I am currently “@Work” on the PC in question so I WIll Implement this evening.

What happens is that the access requests travel through the driver stack along the chain. If any of the divers fail then the buck stops at that point and whatever the request is simply fails.

I documented this somewhere possibly on some forum, but it’s a long time ago and I can’t remember where.

I did an additional search of the registry on my computer and found the entries related to the driver stack example I posted.

"DriverDesc"="Microsoft Storage Spaces Controller"

"DriverDesc"="WinCDEmu Virtual Bus"

"DriverDesc"="Microsoft iSCSI Initiator"

Got to put in a disclaimer here. Anyone who messes with the Windows Registry could render the operating system quite unstable and even cause the operating system to fail. Messing with the system registry is done at art your risk. (“Your” applies to “Everyone”.)

Well the Microsoft simple answer…Try the same thing, this way, through troubleshoot devices, FAILED…

The troubleshooting wizards don’t always work. Just curious. If you start the computer in safe mode, can it then access the USB external drive? Not sure it it will. Safe mode is designed to start Windows in a minimal state.

No Joy in safe mode, Did not really expect much success, Unfortunatly I have been @work On the PC All Week, with no real time to continue on. the Wizard was a microsoft supplied solution that I had already done in another way through device manager, and it failed the same way. On another note, I am soo Glad I spent the extra money on the SSD’s from Samsung as I originally posted, I Did Submit there as well Samsung’s disappointing official reply was:

Dear Customer,
Thank you for contacting Samsung Support regarding your concerns and inquiries. We apologize for any inconvenience this may be causing you. Can you please contact Western Digital about this issue?

Thank you for contacting Samsung and have a good day!

Is the partition schema on the MyBook Live GPT or MBR? I have to admit I’m lost with this one. Chances are if I was sat in front of your computer I would possibly get it working, but unfortunately that’s not an option. If it can’t start just on that one computer then I believe there is something on your computer preventing the computer accessing it.

To eliminate the hardware the next thing I would try is create a Live Liniux CD or USB drive and start the computer from that and see if Linux sees the problem drive and can access its files. If it does then for sure it’ll be something wrong with the Windows installation.

@Myron Thank you fro your help, found this in my journeys may be good
reference for filters we started with…

Thanks for starting that resource. As soon as I saw UpperFilter and LowerFilter, all my memories came flooding back. One list of filters get processed before a request gets to the device driver and the other set of filters get processed after the device driver completes its task.

What you could do is make a copy of the upper and lower filters and you could take the filters out for the purpose of testing with the intention of putting them back. Possibly take each filter out in turn until you take out the filter that’s causing the fault.

One only issue with that. It’s not working when in safe mode. If there are any filters then still try a process of elimination. I’ll have to look if the filters get processed while the OS is in safe mode as I can’t remember. One would assume that the filters are not processed while operating in safe mode,

Thank you so Much Myron, for your assistance, I have spoken to WD Support, (FInally had time, Yes I Work In a WFH Call Center Support Dept. too) WD Basically sent me to Data REcovery, I can pretty much do that and am about to take the drive out of the enclosure, and Go Medevil/Linux on it.

1 Like

Hi Mark,

Were you able to recover the data from your disk? I’m in a similar situation. WD pointed me to data recovery, and data recovery quoted me $700 even though I am under warranty. I wanted to see if you had any luck mounting the drive on a linux box.