WD My BOOK unable to configure. Prompt error System is Busy

Currently I’m facing a problem with my WD My book, the problem is it give following error message while configuring the administrative task.

“ERROR: System is busy now! Please try it later.”

I even hard reset the drive but the problem did not solved.

Every time when i log into my web interface after login initial setup begin when i hit the finished button above error appeared and initial setup start once again.

Any one can help ?


Which My Book do you have? What configuration are you doing? .

This is the same situation I have encountered.

Attempts to access the main configuration screen (Initial Setup) on my WorldBook2 always yield the same result. “Error: system is busy now, try again later”.  No other setup sceen can be accessed.The unit blinks once a second forever.

This has been going on for months. I can write to the device and read from it but the date cannot be set, so the unit sets filedates from dec 31 2000 on until powered down, when the file dates resume at the dec 31 2000 default.

I have inserted the paper clip for the requestite 10 seconds and the unit has restarted, but the result as always the same, Inital setup gets to the summary screen and then displayes the grotesque “Error: system is buys now, try again later” and returns me to the EULA acknowledgement screen on the Initial setup page.  The system disallows me from going any further to access any other setup screens. 

[deleted]  Why can the system not be reset to factory defaults from the outside via some switch combination?  Should I take out the disks an reformat them?  When removed and attached as usb drives, WIndows 7 sees some number of partitions, but does not mount them. If I reformatted the disks would the device be smart enough to build them to its own requirements? WD is mute and blind to all these problems. I have seen this problem described on the web for two years now, now solution has ever been offered. Disgraceful and shame on WD.

Some of what you said was not necessary, and in violation of our useage guidelines, so I edited your post.  However, I’m looking into this for you, right now.

Thanks for looking into this. BTW, In a previous career I woked on drive firmware (defect lists and vendor uniques) for 1" drives, so I am particularly annoyed by lazy error handling. 

Sorry, it took a while.  However, the answer I got back was that it was either a bad drive or corrupted firmware.  In either case, they suggest that you RMA the device.