WD My Book Studio on Windows 8.1 Sleep Problems


I know the WD My Book Studio is a ‘designed for Mac’ external drive, but… it is a hard disk and it was the best one available in the local PC World with 4TB space.  A quick remormat from HDFS to NTFS and job was a good one, or so goes the theory.  I’m beginning to regret this purchase decision.  Yet my expereience of other WD products is good, so this is disappointing.

The issue, which is well documented on both your site and elsewhere on the web, is the drive goes to sleep and will not wake up once it has slept.

My use case was to use the drive to host Hyper-V based guest OS’ as the space constraints on my PC system disk are limited.  I currently can’t do this because of the sleep problem.

My PC is a GigaByteGB- BXi7-4770R. 16GB RAM 250GB mSATA SSD.  The BIOS setting for xHCI is set to Auto, the only other setting is Smart-Auto.  I’ve tried both and both result in the same sleep problem.

My OS is Windows 8.1 Update 1.  Have have set the power settings to ‘High Performance’ and both the Hard Disk Sleep and USB Selective Sleep set to “Off”.

I’ve tried using the WD Windows Software, but this had no impact, the drive continues to sleep. 

in terms of physical connections, the WD My Book Studio only has a proprietry WD cable, so I can’t test it with another cable, but the cable, which was new out of the box, looks good, and it does work when the drive is not asleep, and acheives a sustained data transfer rate of 140MB+ second as I transfer OS Guest Images about.

The WD SES Driver is the one supplied with Windows 8.1 Update and has a version of 1, 0, 7, 2 and is supplied by Western Digital.  This driver disappears from the PC installation when the My Book Studio sleeps.  Installing the drivers manually results in a fault “This device is not working properly because Windows cannot load the drivers required for this device. (Code 31) The specified request is not a valid operation for the target device”

I have also applied the fix detailed at http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/01/help-after-installing-windows-8-1-my-usb-drive-disappears-or-file-transfers-stop-unexpectedly-r-a-post-title.aspx using PowerShell, to disable sleep. at the drive level.  All to no avail.

Lastly, I have also applied the Windows Rollup Up Fixes at http://support.microsoft.com/kb/2911106, but even reverting the drive to Windows 8 drive management power behaviour hasn’t worked.

The Challenge :smiley:

So, I am hoping that Western Digital can rise to the challenge I’m about to set, and create a firmware update for this device that allows your customer to manage the My Book Studio’s sleep settings manually. 

  1. Is WD up for the challenge?  or,
  2. Should I just take the device back to PC World and ask for a refund and buy another device?



(still a happy WD customer… just :wink: )

Hi, have you tried to setup the sleep timer using the drive utility? 

WD Drive Utilities for Windows

I just found it lol  what an ejit I am.  I looked at this app too, but didn’t spot that facility.  Am off to Specsavers as we speak :wink:

many thanks for pointing the way @jubei04.  This customer is happy again :smiley:  and ever so slightly embarresed :manembarrassed:



So… You know I found your utility and used it to turn off the sleep setting. Well, basically, it doesn’t stop the drive from disappearing when connected to Windows 8.1 Update. In fact it disconnects from the OS following a reboot after about 5 minutes. This is completely frustrating, as I’m sure you can imagine.

What do you suggest I do know?

To date I’ve applied the Windows update Rollup package that is supposed to revert the drive behaviour to Windows 8 configuration.
I’ve used the MSDN PowerShell script to Toggle the Drive sleep behaviour to disabled, but that doesn’t stop the drive from disappearing from Windows.
I’ve applied WD’s latest drivers to, and software, but all to no avail.

Looking forward to the next reply.