WD My Book Studio II + Mountain Lion GM

Hi,

I have a My Book Studio Edition II. When I had Lion installed it worked just fine, sleeping with the Mac, and waking up when the Mac woke up.

However, since I installed Mountain Lion GM the drive randomly goes to sleep (no lights on the front; the WD RAID sofwtare disappears from the status bar), and the only way to wake it up is to cycle the power.

Is this a problem with Mountain Lion, or indicative of a seperare hardware issue?

If Mountain Lion, does anyone know when a firmware / software update will be release?

Mountain Lion will be released later today…

Regards

Darren.

To confirm if it is a hardware issue you may test the drive connected to another computer. The issue might be related to 10.8 only, since it is very common that issues may arise with an OS update. 

I had a similar issue with my Studio 3TB unmounting randomly.  WD SmartWare would still see the drive as “powered on” and would give me the option to remount the drive.  But would not stay mounted.  My external was also my iTunes media drive.  So it seemed to disappear as soon as I would open iTunes.  I setup a call with Apple and worked through this issue.  Here is what they had me do just in case it can save someone else the time/call.

Step 1 - Shutdown your Mac. 

Step 2 - Power on and quickly press and hold Command + Option + R + P

Step 3 - While still holding Cmd + Opt + R + P, wait for the white screen and chimes to occur TWICE

Step 4 - Upon rebooting, and if you are using your external as iTunes media drive, hold OPTION and click to open iTunes

If you arent using the external for iTunes then you may not need to do Step 4.  When Mountain Lion finished and I opened iTunes for the first time, my media folder setting in PREFERNCES was empty.  So I had to set that back up, reauthorize my computer for my purchases to show up on my Apple TVs.  So those may be extra steps you may have to do if you use your external for iTunes Media as well. 

I hope that helps! 

Update - It unmounted on me, but it did take longer.  I then resinstalled ML again from recovery HD.  That didnt work.  Apple suggested I wipe internal and do a fresh install.  I also had a problem where DVDs would not stay in the superdrive.  It kept mounting and then mounting and ejecting the drives.  :(  

Upon wite and resinstall of ML it seemed promising.  The super drive would read and retain the DVDs.  I also grabbed the newer Turbo drivers released same say as ML (which say supports ML.)  10 minutes later the drive unmounts.  The crazy thing is I can see the drive through Smartware… it will even run tests on the drive while unmounted.  

Apple will be calling me back tomororw to confirm I got moved back into my machine.  Luckily my Time Machine back up is on a Lacie Network drive.  But obvously this was a day completely waisted chasing my tail.  I emailed WD earlier in the week and have not heard anything.  I will be giving them a call since their general support line is open tomorrow.  

This is stupid.  Its a universal USB/Firewire drive.  I can understand networking changing… but seriously… no excuse this should not be working on day 1.  

Hi,

Similar problem here, I upgraded to Mountain Lion 4 days ago and today the My Book Studio Edition II stopped working (front light off, WD manager icon disappeared from status bar, partitions on the drive disappeared from Finder device list).  My system is new but the drive has been working fine until now (for 3 weeks now).  Rebooting my iMac did not bring the drive back to life!

Thinking there might be new software for Mountain Lion, I visited wdc.com and saw that “Turbo Drivers” have a Mountain Lion update from late July.  I downloaded it and "WD Drive Manager’, installed both and rebooted.  The drives are now working but I still ove no status bar icon for the drive manager and I discovered the following message in the console log:

15/08/12 3:37:01.936 PM com.apple.launchd.peruser.501[119]: ([0x0-0x27027].com.wdc.drivemgrstatusmenu[640]) Job appears to have crashed: Bus error: 10

I don’t know when the drive actually stopped working… I’ve been using it without problems for several days since the Mountain Lion upgrade but it seems to me unlikely that the two events are unrelated.

There is a crash report associated with this log message… should I send it to someone at Western Digital?

If not, any other advice or general guidelines about keeping my WD software current with operating system release changes?

With thanks in advance,

I just noticed a WD notice for a new version of New Update - WD Drive Manager (Mac) Version 2.2.6 (8/15/11), posted shortly after my previous message.

I’ve downloaded the installer and it gets a little further than the preceding one… it doesn’t crash on launch and a WD icon appears in my status bar.  Unfortunately that’s as far as it gets since the icon’s only command (“WD Drive Manager v2.2.6”) is greyed out !

I do notice that more processes with “WD” in the name are running now.  Prior to installing the new version,  a “ps aux|grep WD|grep -v grep” command produced the following:

root 78 0.0 0.0 664772 1532 ?? Ss 10:35AM 0:00.05 /Library/Application Support/WesternDigital/WDDriveManager/WDDriveManagerService

Now I get:

root 633 0.0 0.0 652484 1484 ?? Ss 10:37AM 0:00.19 /Library/Application Support/WesternDigital/WDDriveManager/WDDriveManagerService
boss 630 0.0 0.0 730636 7284 ?? S 10:37AM 0:00.21 /Library/Application Support/WesternDigital/WDDriveManager/WDDriveManagerStatusMenu.app/Contents/MacOS/WDDriveManagerStatusMenu -psn_0_143395

So we can see the status bar app running (it you have multiple users, there’ll be a copy for each currently logged on user), but that’s as far as it goes.  You can’t do anything with it.

It’s good to know that WD are working on the Mountain Lion problem but it seems it isn’t quite fixed yet.  Or is it me?

With apologies to WD for my previous, too-rapidly posted message, the new WD Drive Manager v2.2.6 works !!!   

The status bar icon now opens:

   WD Drive Manager v2.2.6  (greyed out)

   WD My Book RAID 1 FireWire   ->  (opens the utility, accesses the drive, gives info and joy like before !)

It took an extra reboot and a bit of patience.  Note that the status bar icon doesn’t appear until a minute or two after reboot… a lot of deep thinking no doubt.  I think I didn’t wait that extra minute or two after the previous reboots… I looked for the icon right away, didn’t see it and reckoned thing were still broken.

T H A N K   Y O U   W E S T E R N   D I G I T A L   ! ! !   :smileyvery-happy:

 

So it you’re experiencing the same problems as describe in this thread, try the new download.  It worked for me.

Hi, 

  1. Is your Mt. Lion OS-X an upgrade from Lion OS-X to Mt. Lion or clean an install Mt. Lion (without any previous operating system)?

  2. Have you tried Retail version (not GM) 10.8?

  3. How is your drive partitioned?  APM or GPT?

  4. How long does it take to fail?

  5. Is 100% reproduced?

  6. Are there any software running?  WD SmartWare or any other 3rd party SW?

9 Have you tried 10.8.1 update? 

http://support.apple.com/kb/HT5418

Macbook Pro 2009, Mountain Lion, WD Drive Manager 2.2.7, connected via Firewire. I continue to get these errors where suddenly the disk unmounts, status menu disappears, and the only way to get it back is to unplug the firewire and then reconnect it to the Macbook Pro. Very frustrating, any suggestions?

p.s. other times, I’ll get a message saying that the disk is in use and cannot be powered down. Again, spontaneously, I’d done nothing to request the disk unmount, power down, etc. And I’ve also got my energy preferences set to not put the hard disks to sleep (with or without that setting, I get the same problem, it has no effect, mentioning it here anyway just to give the full picture).

Hi,

Uninstall the WD RAID software.

As soon as I uninstalled it the drive stayed connected. However, the drive will still “sleep” when inactive.

You should set the drive sleep preference to your preferred setting before you uninstall the software.

Regards

Darren.