WD My Book Studio Edition II - extremely slow


#1

There has been a few posts about My Book external hard drives being slow but nowhere I can find solutions or even proper technical info. It doesn’t look like WD reps/techs check these forums so we are left to just troubleshoot amongst ourselves.

Here’s background info about my system setup:

  • MacBook Pro

  • Processor: 2.6 GHz Intel Core 2 Duo

  • Memory: 4 GB 667 MHz DDR2 SDRAM

I am a professional photographer and I bought My Book Studio Edition II (RAID 1 config) hoping to archive my large library of digital images (DNG, RAW, JPEG, Lightroom catalogs). Unfortunately this hard drive is extremely slow. Just as example I transferred 126 MB from my CompactFlash memory card to the laptop’s internal hard drive via USB 2.0 and it took about 5 seconds to complete. Same files transferred from internal hard drive to My Book Studio took over 2 minutes. Then to compare outgoing speed I have also transferred those files back to memory card and it completed in 12 seconds.

Here’s full data I was able to collect in my testing (exact same files 126 MB):

CF card (Sandisk Extreme III) -> MacBook Pro internal hard drive  … 5 seconds

MacBook Pro internal hard drive -> CF card (Sandisk Extreme III) … 12 seconds

MacBook Pro internal hard drive -> My Book Studio Edition II (FireWire 800) … 136 seconds

My Book Studio Edition II (FireWire 800) -> MacBook Pro internal hard drive … 13 seconds

MacBook Pro internal hard drive -> My Passport Studio (USB 2.0 & FireWire 800) … under 5 seconds

My Passport Studio (USB 2.0 & FireWire 800) -> MacBook Pro internal hard drive … under 5 seconds

I have also started testing this drive with USB 2.0 but I’ve stopped after 40 seconds. It obviously isn’t the problem with cables or ports because I have tested them with other external drives. I have installed latest firmware and WD Macintosh +TURBO drivers. No noticeable improvement.

There’s one other alarming problem. My Book Studio is setup to work in RAID 1, but while transferring about 4 GB of files, WD Drive Manager changed status of the drive to RAID 0. After transfer completed it returned to say RAID 1 again. Could be a sign of a failing hard drive but why status info for drive A and B states that both are good.

I hope that above info is detailed enough for one of WD tech support guys to respond and provide a solution for all of us.

___________

UPDATE:

Please read through. It might not work for everyone.

Accessing the drive became almost impossible. It was taking forever to just browse through folders. I have pulled out one of the drives. With only one drive still inside the enclosure, I have connected it to the computer. After RAID failure error message I was able to access the drive and it was fast and responsive. That gave me enough time to transfer all my archived images to a new external drive.

After all files were safe I have decided to do some more testing to see if the problem is the hard drive or RAID connection. I have swapped the drive and I was able to access it but when I tried again later it stopped mounting and was invisible to the computer. I guess it’s dead now.

Sending to WD for replacement/repair.


#2

Did you ever resolve this issue?  I’m having the exact same problem - using a MyBook Studio Edition II with a MacBook Pro and it is terribly slow.   I’ve also tried different cables, USB vs. FW800, and it doesn’t seem to make a difference.

Here are some simple tests:

Read 1GB file from MyBook Studio Edition II : 33 seconds

Write 1GB file to MyBook Studio Edition II : 17 minutes! (yes, that is minutes, not seconds)

Write same 1GB file to an external Lacie drive: 33 seconds

I’m beginning to fear this purchase was a waste of money. 


#3

Hello,

I have an MacBookPro5,5 13inch, 10.6.2 OS.

1 WD MyBook Studio 2TB

1 WD MyBook Studio Edition 2TB (2drives= 1TB+1TB)

The 1GB file used for this test includes: .mp4, .mov, .dmg, .txt, .png, .pdf

Here are the result from 3 tries from each unit,

All Firewire 800 connections

WD MyBook Studio 2TB:

1.  17 sec. 

  1. 18 sec.

  2. 18 sec.

WD MyBook Studio Edition 2TB (2drives= 1TB+1TB)

  1. 26 sec.

  2. 24 sec.

  3. 22 sec.


#4

Just bought this drive on Monday and it’s giving me major issues on my Win 7 64bit PC.  I’ve tried USB, FW800 and eSata all with frustrating results.

USB and FW800 will transfer a 1GB test file, go nice and fast for about 95% of it, then the speed dwindles and it just sits there doing nothing for at least 10-15 minutes.  I look at the drive light and it looks like it’s IDLE (the indicator light on the front no longer shows it’s “writing mode” but rather the capacity mode).  Why is it doing this!?  Why hasn’t Western Digital fixed this!?  I’ve updated to the latest firmware (had to do it on my Mac since their FW updater doesn’t support a 64bit OS (of course, it’s 2010, why would their firmware work on a 64 bit OS?)

The only interface that works well is eSata, but then their WD drive manager no longer comes up so I have no status on the health of the RAID, but I guess it’s good that eSata is the fastest of them all.

The “power button” on the back seems to have a different effect on the drive every time I press it.  I never know what the indicator light is telling me on the front except when it’s writing data (flashing up and down the line).  I usually have to pull the power on the drive to get it to turn off fully.

PLEASE FIX THESE ISSUES WESTERN DIGITAL!!  I really want to like this drive, it has everything I need in theory (RAID 1, multiple fast interfaces, great design and love the quick access to the drive), but this drive fundamentally does not fully work as it is supposed to.

Has anyone ever tried swapping out the internal drives with another type of WD drive?  It seems these “green” drives like to power themselves down even in the middle of file transfers.  Why are they doing this?


#5

Remember that if you have the drive set up in RAID 1 (mirrored), performance will be a little slower as it needs to write the data to both drives simultaneously.

For best performace, and faster read/write times, use RAID 0 (striped) - although this is at risk since there will be no automatic backup…


#6

Bashir,

That would be valid logic if all three interfaces (USB, Firewire800, and eSATA) all had the same performance issues.  However, as I wrote, eSATA does not suffer from the “fast transfer for 90% of a 1GB file > slows to a crawl > hard drive goes to sleep > after 15+ minutes hard drive comes back to life > file transfer FINALLY completes” issue.  There are drawbacks to using eSATA though such as no RAID monitoring and it’s not hot swappable (as far as I know).

Has anyone else experienced this issue using eSATA?


#7

I am having, as others have said here, the exact same issue. I’m dual-boot Windows 7 64-bit and Ubuntu 10.04 and by no means do I have  a slow machine; yet the MyBook 1TB brings me to a screeching halt. I use the Firewire mainly and I’m impressed that I’ve been able to get over 100 gigs of data on it, although that involved me setting up a transfer and leaving for a long period of time. For the $150+ dollars or so I paid for this drive and the time spent reading reviews, I expected it to run flawlessly.

Other issues besides transfer speed are general lock-ups of the drive and/or Windows Explorer, and also the inability of the computer to boot into any operating system if the drive is plugged in when first turning the computer on. I get to the HP screen and then it just goes blank with a blinking white cursor.


Edit: I have tested the external hard drive in Ubuntu Linux 10.04 and it seems to work excellently!

I have copied files from one partition of my internal hard drive to the external hard drive, with file sizes ranging from 2.5-3.5gb at speeds of around _15mb/sec, never dropping below 13.9mb/sec. _These speeds were achieved using Firewire. While I believe it is capable of a faster transfer, the important part is that nothing locked up during this process, even while I was multitasking on three different desktops. The status light isn’t working correctly, but everything else is.

I know this won’t sound like a very good fix, but if there are files that you must transfer onto the hard drive, I bet you could run the Ubuntu 10.04 Live CD, mount your main hard drive, and transfer files that way.

Note: I am running a 4 Circut/6 Circut Firewire400 cable into a laptop that only has the 4 Circut port.


 

If anyone here has any ideas about this, please post them. I have read dozens of posts by now all with the same complaint. In the mean time, I’ll try a few things and post here with my findings.


#8

I see similar issues, I have two 2TB Studio II units, one works with 10.3 Mac mini and is now little bit better with turbo drivers, before it was slow as hell.  I have arroung 40000 RAW photos on the disk and I am using LR2 and 3. 

WD has serious firmware issues but I have not seen any reaction from the company.

Second one is connected to AEBS and is incredibly slow, may be 1 Mb/s or so, the drive does not work at higher speeds when connected to 10.6 macbook with firewire or usb. 

All in all, do not buy WD  any 2.5" modern laptop drive is 2-3 times faster than WD-s drive.  


#9

Hi - I just received the 4TB MyBook Studio Edition II.  For once in my life, I followed the instructions to install it.  After the setup was complete, I tried to transfer several large folders.  Some transfer at about 1MB/Minute, another transfers really fast until it reached 500MB, then it crawls.  I went to the support site and upgraded the firmware, rebooted the Mac and the drive - didn’t make a difference.

I am using a Mac Mini Server 10.6.4 and have the drive connected using Firewire800.

I called the technical support line and ended up with a call center in India - surprise…  The woman tried, but I had to have her repeat herself 4-6 times.  She finally said some of the drives have hardware issues and did I want to send it in for replacement.  I asked her what she wanted me to send - the drives or the whole device.  She did not know.  Needless to say, I am going to exchange the device and give it another shot.

She had me verify the drive in Disk Utility - it was okay.  I have tried both Raid 0 and Raid 1 and have reformatted the drive.  Nothing has corrected the issue.  I really like the concept of this drive and it has had such good reviews - I really hope I just got a dud.  Unfortunately, it sounds like this is a common issue.  If the second device fails, I will not try a third - I will just try a different disk array.

If your drive does this, don’t waste your time trying to diagnose it, just return it in exchange for another drive.  Maybe after enough returns, someone will pay attention to quality control.  This is very unfortunate - I have had good experiences with WD in the past and have had a MyBook 1TB USB drive for several years now.

I will update, once I have some news.


#10

While the 4TB MyBook Studio Edition II is considerably larger than my 1TB MyBook, I have remedied my earlier problem. Firewire is not the way to go, at least for me and at least on Windows 7 64-bit. The USB connection works just fine in Ubuntu and Windows. It’s still not as fast as I’d like it to be, and it’s still very touchy if you knock the cable, but it can at least transfer files at a reasonable speed (10+mb/sec) to and from the drive. For a laptop without an eSATA connection, I’ll just have to deal with it. Anyone else with my aforementioned problem should be able to get by with USB. If you have found a faster way to transfer files, please share that information here. A problem not solved was the status light; that still either shows it as half or totally full. Also, this could be a nit-picky thing, but there is no icon for my drive – just a broken/missing icon symbol – and I have found no way to change it.


#11

SAME HERE!  After my two drives performed well for well over a year using firewire 800, I am now experiencing the same symptoms.  I use one drive to back up the other, and copy operations are now always interrupted by mysterious long pauses where the drive is 100% busy but no data is being transferred.  During this time the white light is lit solid from top to bottom, then it begins a slow up-and-down pattern while the copy is at a standstill.  After several minutes, the copy resumes and stats will show normal, fluctuating, disk usage and acceptable transfer rates.

If Windows initially estimated that it will take 2 hours to transfer the folder, each long pause causes the estimate to become longer and longer.  20% into the copy it now estimates completion in 11 hours if performance doesn’t get even worse.  If you have the patience, the copy will complete without any errors.

In opening a ticket, WD missed the whole point and responded that the drive spins down after 10 minutes when it is inactive.  Oh, is that so, right in the middle of a copy?  Well, that’s disturbing enough indeed, and just shows that either they didn’t understand my symptoms or that they simply chose to ignore them.

Also, opening certain files on the drive sometimes takes forever, and a thumbnail display of a certain photo will get hung up for several minutes before it finally refreshes.  And the most disturbing thing is that sometimes the whole drive will disconnect itself and I have to hold the power button in the back to turn it off/on.  Then it will reconnect until the next time it happens.

Windows 7 claims the drives are working normally.  But after reading these posts, I’m beginning to think that the drives only last a year and that these symptoms are indications that the units are struggling in their final days before they go belly-up.  The long pauses are probably some kind of built-in error-recovery mechanism that WD probably doesn’t want to expound upon.  WD - you can chime in here;  I don’t want to spread misinformation, but your insight would certainly be helpful in this forum (read:  vacuum of useful information) that you’ve created for us.