WD My Book problems on Mac

Hi Everyone,
I have had a WD My Book 2TB/USB2 version for just over a year and started having some very strange problems in the last month. The permissions keep changing to I can only Read and not write files to it. Running Disk Utility the drive cant be unmounted usually, dragging the icon from the desktop to the trash and then running disk utility seems to work always find a problem with:

Checking volume bitmap.Volume Bit Map needs minor repairRepairs the file succesfully, then verify it again appears to be OK and then same problem with volume bitmap next time you run disk utility…

Seems to be slowing down the finder, looking in the drive at the files on there seems to take a very long time for the contents to appear and copying files out to back up for reformatting (when the permissions are correct) always throws up 'data could not be read or written (error code -36)Opening a small indesign file from the drive locks up indesign for 20 minutes before opening… As I cant backup the data from it to another drive without getting a finder error. Should I risk doing a firmware update to see if it helps?

I’m running Leopard (10.5.8) on mac book pro, usb cable straight into the macbook pro, My Book is mac os extended format. Still with 82 Gb available…
Any help or guidance would be very much appreciated Thanks!

which my book are you using?  have you tried defragging the drive?  is it possible you have some file corruption on the drive?  have tried drive repair?  also, try another usb cable.  

Hi Wayne, sorry for delay and thanks for the questions:

I’m using a WD My Book 1110 Media,

mac GUID partiton formatted to Mac OS extended (Journaled) as instructed.

Have tried disk utitlity first aid:

Always comes back  ‘Volume Bit Map needs minor repair’ always wil fix it and then same problem again and very rarely can it dismount the drive to repair unless I drag it the trash to dismount.

and disk warrior a few times, first 

'DiskWarrior has successfully built a new directory for the disk named “Vans 2TB.” The new directory cannot replace

the original directory because of a disk malfunction.’

• 1 file had a directory entry with an incorrect text encoding value that was repaired.

• 1 folder had a directory entry with an incorrect flag that was repaired.

• 475 folders had a directory entry with an incorrect custom icon flag that was repaired.

• Incorrect values in the Volume Information were repaired.

Second time it did manage to replace the directory but didn;'t change the problems with the finder hanging and most apps not repsonding while the drive is plugged in.

Checking files in DIskwarrior brought up a lot of

‘An unexpected error ocurred while attempting to perform the file operations.’ and tried a different USB cable and it ona  different Mac running 10.4.11 and the same finder issues and super slow copying files off it to a different USB drive to back up before tryign to update the firm ware and reformattign etc…

About 8 hours to copy 1.8Gb?

Any help would be much appreciated

Many Thanks

Jasper

Sounds like it is dieing. Save your data else where quick.
To push it over the brink into complete failure ( after retreiving the data) Try some secure erases and duplicates.

Monitor the disk activity rate in Activity monitor and see how it does.

Check the power supply by useing another compatible one, scrub the disk and return it. 

Disk fail - and not just when drive is past warrenty date.

Cheers

Gannett