WD My Book Premium Edition 500 GB

I have an old My Book hard drive that I am trying to reformat to FAT32.  Sometimes when I plug it into my computer (running windows xp) it recognizes it, but when I try to use the FAT32 program from WD, it says that the “program cannot determine the size of the hard drive” and sends me back to the start of the program.  Other times, the hard drive just shows up as “WD USB Drive” and is in device manager, it’s in the task bar under the WD button manager, but cannot get to it through My Computer.  Someone please help…I’d really like to get this dinosaur up and running :).


Do you see the drive under Disk Management? Have you test the drive using a different computer?

Yes, it’s under disk management that I see it listed as the two different names I gave.  I’ve tried using it on another computer running windows XP with the same result.

Ok…got it to at least be recognized whenever I plug it in, but now, when I use the FAT32 Formatter from WD, it starts formatting then comes up with “Error!  Cannot write image to disk!”.  Any suggestions?

try this  http://www.softpedia.com/get/System/Hard-Disk-Utils/SwissKnife.shtml