WD My book Passport 2TB Will not Initialize because its write protected

Hey all,

I just recently purchased a WD My Book Passport 2TB, I used it for about 2 weeks, moved it in between my computers(home network was a mess), it worked fine, that is until i left it on my server computer(Windows 7 32 bit new network dedicated server I’LL provide pics) . I transferred ALL OF MY MOVIES and my tv shows on the drive. After I transferred them(Over the newly redid network) I shut the lid to my laptop(win 7 64bit 6gb ram 600gb HD) after it was done transferring. well movie night comes along and i cant access. I told my friends one minute let me bring the drive and hook it up to the laptop, idk whats wrong. I unplugged it(properly), took it to my laptop and attempted to use it. it didn’t recognize the drive, I went into the computer mang looked under device mang and saw it there, so, i went to disk manager to see why it didn’t have a drive letter, it was all unallocated, and not intialized, after a bit of tinkering, i found that the right click has options, i selected Intialize to try to start the drive, as soon as i did, it asked what to read the drive as GPT or what ever the other was, i tried both and both times its said write protected. I read a few other forums to see if i could figure out the problem, to no success, I DO NOT HAVE ANY WD SOFTWARE INSTALLED so no encryption on my part. what do I need to do to correct this mistake, problem, defect, all i want is my movies and shows, either way im taking it back. oh i hooked it up via usb 2.0/.1(depending on if it was the laptop or server).

what do i need to do to fix this?

Untitled.jpgserver pc win 7 32 bit

Run CGSecurity TestDisk on it to repair the partition table.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en