WD My Book Not working

Hello. This morning when I plugged my WD My Book 1.5 TB external hard drive into my computer, it didn’t show up on my computer. It gave me an error that “Device driver software was not successfully installed.” I run windows 7 on a brand new laptop that I just got a few days ago, but have used the drive on with no problems on before today. I tried plugging the drive into all the USB slots on my laptop, and none of them made the hard drive work correctly. I decided that I would try pluggin the hard drive into my desktop computer, which it has been working fine over a year, but still, no luck getting the drive to work. I went into the disk management on both computers and the drive comes up as 'not initialized" and “unallocated.” The strange thing is, it’s a 1.5 TB hard drive, but 2047.35 GB of unallocated space comes up. I have not tampered with the hardware of the hard drive at all, and have tried looking up may different solutions, but could not find anything that helped to fix the problem. Have I lost everything that was on the hard drive? Will I have to send the drive in to get it replaced? The strange thing is, I used the drive just last night and did not do anything to it besides unplug the USB cord from my laptop before going to bed last night. Any help is appreciated. Thank you.

It sounds like something got corrupt. Do you always remove the drive safely? Just pulling plug can cause corruption. TestDisk http://www.cgsecurity.org/wiki/TestDisk might fix the problem.