WD my book live DLNA intermittently disconnects from Samsung TV


I know there are many forum entries about this and I also found work arounds for the Twonky server.

But running the latest WD my book firmware with WD’s own media server, I still get this issue, which is very annoying and difies the whole purpose of a media server.

I’ve tried a lot of things, turned off the energy saver (harddisk sleep), wired up the TV instead of using wireless, etc. But I am getting the impression that it’s a software error in the DLNA server.

Would be great if someone from WD could comment if a firmware update for this is planned or on how to workaround this for the time being.



Hello MarcBee, have you tried setting a static IP for the My Book Live? This should give you a more stable connection. Check page 66 of the manual.


Thanks Ichigo for your help. Appreciated.

I’ve changed the config yesterday and will test it for a few days and then report back.



Hi Ichigo,

still same issue :cry:

I’ve watched a few movies, some I could watch completely, others disconnected after 20 mins and 40 mins.

It’s very frustrating, as what good is a NAS which doesn’t work reliably. Plus, in connection to the fast-forwarding not working, it’s very painful to continue watching a movie.

Do you have any other idea? Thanks,


Hi again, have you verified if the disconnection problems also happen with your PC or any other devices? Also check if there are any firmware updates you can do for the TV.

Hi there.

Yes, I can confirm when running a dlna server (ps3-mediaserver) on my mac, then the disconnection doesn’t appear. 

Also, the TV (Samsung UN65F9000AF) is up to date. 

It all seems to point towards the DLNA on the my book live being the culprit. Do you have insight, if there is a firmware upgrade planned, which might tackle this issue?