WD My Book Live 3TB Keeps resetting IP Address. Help

I purchased a WD My Book Live 3TB Network drive. I set it up and everything works fine. I noticed that to transfer my media to this drive takes FOREVER which **bleep** but I can live with that. Unless of course anyone out there knows how to fix this problem and speed it up a little. Anyway, on to the problem.

So because it takes ages to transfer my files to this network drive, every so often it will run into an error saying that the file that I am transferring can’t be found and my guess is that the connection drops from things like microwaves or other frequencies going on in the house. Sometimes I can still get into the drive and just erase the folders that were not completely transferred and I can start over. However, on two occasions, after this error happened while trying to transfer data to this network drive, my IP address was changed for the drive. I couldn’t get in and ended up calling Western Digital Tech Support. After about a half hour I figured it out myself that the IP was changed. WD tech support was not much of a help at all but that’s another story.

My question is why did my IP address get changed? How do I stop this from happening? And also is there a way to transfer files faster on this thing? Any help apprecitated. Thanks.

I would like to add that the second time it happened and I could not get into the setting of the drive using my Dashboard shortcut on my desktop, I pulled up the WD Quick View to check what if the IP was changed and sure enough it was changed again. I do not want this to happen everytime I run into an error. I been transfer music and videos. I even cut it down to only a few Gigs at a time because it takes so long. Right now my main concern is the changing of the IP address. Please help. Thank you.

Hello, what transfer speed are you currently getting? You have the option to setup a static IP from the My Book dashboard,  if a static IP is not manually selected, the router will be the one that assigns the IP every time. Check page 66 of the manual for more information.



Have you set it up with a fixed IP adress ?

I leave my MBL as dhcp, but reserve and IP for that device in my router’s dhcp settings, so it’s always getting the same one