WD My Book hangs my PC on boot up

Hi i’ve been having this problem since day 1 wih my WD My book (WDBACW0020HBK) wherein if its connected via USB3.0 cable into my USB2.0 PC port im experiencing the following problems.

  1. PC randomly hang up during boot up. Im using windows 7 and it hangs during the bios detection, It does not even get into the part where windows shows it “Windows Starting” message.

  2. I have two external drives, 1 is this WD and one seagate, randomly either one will not be detected, or the drive mapping changes which affects of my programs that autosave to my wd and seagate drives via the drive letters already stored in their configs.

To temporarily resolve #1 above, i have to reboot the PC a number of times.

For #2, i just reassign back again the drive letters.

I primarily used my WD drive for whole PC backup and currently to avoid the above issues, i just dont power up anymore unless the backup is scheduled to run for the day or my programs will need to write into them. Yes they dont occur if my WD is not powered up.

My WD Smartware version is

Any advise on how to resolve this permanently ?



correction the version above was for the WD Quick view. the version im using is

i plugged in after posting above my WD drive and noticed that there is an upgrade available: However after the installation, it asked me to reboot, and yes my WD is still plugged and powered up. So i rebootted. And issue #1 above encountered immediately. Evidently the above upgrade didnt resolved the hanging issue. Im not back in turning off the drive.

I’m having the same problem on a Vista PC.  If the drive is disconnected, it boots up perfectly.  If the drive is connected and turned on, the computer never gets to the little scrolling indicator that shows Vista is loading.  If I shut down and restart again with the drive connected, the computer gives the failed to start message, does a scan, finds nothing wrong and prompts me to do a system restore.  Again, I unplug the drive and it boots right up.

FunkHouse did you check the BIOS and make sure it’ not set to boot from USB?


Im also have the very same behavior of funkhouse9. Joe, yes i’ve also verified that BIOS setting. 

80% of the time the problem doesnt happen when i just plugged in the my whole system in the electric outlet and wait for the light infront of my WD to stop blinking. That is, once the light stop blinking and has itself fully lighted that’s the time i turn on my PC. But again, that doesnt even solve the problem completely. And even if it does, i will be very disappointed in having this drive having this peculiar behavior on bootup.

I went into the Bios last night and the boot order was set to:

  1. Onboard or USB Floppy Drive (Not Present)

  2. Onboard SATA Hard Drive (Not Present)

  3. Samsung SP2504C

  4. Onboard or USB CD Rom Drive

  5. USB Drive

I removed #1 and my computer will now boot up with the drive attached.  But, I don’t understand why it would be seeing the WD drive as a floppy drive.  I have other external USB drives connected which have never caused me a problem.  So, although I seem to have gotten around the problem, I’m not sure that I feel like I’ve solved it.

There may be some conflict with USB involved. One other thing that may cause that problem is having USB legacy devices enabled. If you disable that then USB mice and keyboards won’t work. I believe I have the DVD drive set first in my BIOS.


I suspect its because there is some incompatibility issue between the usb3.0 interface of this drive and plugging it into a usb 2.0 output port of the PC which was advertised in the drive that its usb2.0 100% compatible. Coz as i have mentioned, i also have another usb2.0 ext HDD and i didnt have these issues on it. I wonder if someone from WD can 100% guarantee this compatibility.

I’m going to need to try it all again, because I’m not convinced that it’s working after all.  I was going through it again last night with the BIOS changes I had made and I couldn’t get it to boot up again.  Making me wonder if I had done something wrong the first time when it worked like leaving the drive off.  I’ll need to make some time to test again tonight.

But, it’s also worth noting that it’s hanging at the scrolling indicator that Vista shows when booting up.  I had originally indicated that it never got to that point, but I’m doubting myself about that now.  I may have to concede that my original post details could have been incorrect regarding what was happening.  I need to go home, reset everything to how it was and get a synpsis of what’s happening that I’m confident in.

If it gets to, but hangs at the Vista scrolling bar, does that indicate it’s a Vista problem and not a BIOS issue, right?

Ok, well I feel better.  With the BIOS changes, it does boot up correctly.  I’m still not sure why disabling the USB floppy drive made a difference when I never had that problem on other drives.  Maybe it’s related to the USB 3.0 on a 2.0 port, but, it works now, so I’m happy.

Hi, can you pls share which specific settings you have changed/disabled in your bios setup?

In my bios the boot order was:

  1. Onboard or USB Floppy Drive (Not Present)

  2. Onboard SATA Hard Drive (Not Present)

  3. Samsung SP2504C

  4. Onboard or USB CD Rom Drive

  5. USB Drive

I took out #1 (Onboard or USB Floppy Drive) so #2 became #1, #3 became #2, etc., and it started working. 


Thanks for the information. Happy that it worked for you.

I checked my BIOS setting and i dont have any setting that boot up via USB or floppy drives enabled. I have as my primary set to my HDD and secondary to my CD ROM, the third option is disabled.

Anyways, i logged a support ticket for this. lets see what they come up with my case.

Good luck!  Hopefully they or someone here can get it cleared up for you.  It’s a bit irritating that it caused problems out of the box, but I was too lazy to return it since I had already run the whole system backup before I discovered the problem.  My PC probably will be due for replacing in the next couple years, so hopefully the next system plays nice with this drive.