WD My Book For Mac 1TB - Spinning but not recognized by iMAC any longer!


#1

Hi!

I installed this drive this morning and backed up about 100 gigs using Time Machine.

After installing WD Smart Ware it asked me to update the firmware which I did. As it was updating the firmware it froze 3/4 of the way and did not want to continue. I waited for a long long time.

I tried to reboot the computer and now the drive doesn’t want to be recognized by the computer.

The drive is spinning but nothing!

Please help!


#2

hi,

you got firmware problem. RMA it if don’t have any important data in it.


#3

What does RMA mean? Like retutn it?

I purchased it from the Apple Store? Should I bring it back to them?


#4

hi,

yeah. return it.  and take new one. you should search data recovery company for help if have important data in it. good lock.


#5

What was the problem? If I get a new one, should I run the firmware update or not?


#6

hi,

it’s firmware problem. like mac. with complete install how can boot the machine?

you no need to update firmware if you don’t have any problem during use it. or you can asking for they update for you when you get the new one. that may more better for you.