WD My Book Essential 2 TB - Windows Will Not Recognize

I should of listened to all the bad reviews before I bought 2 of these WD My Book 2tb drives for my business.

I am a Web Designer\Microsoft Certified Systems Engineer (MCSE) and stored all my content on this drive for backup purposes.

Isnt that what the My Book was intended for???

All my Web Design templates are gone along with hundreds of hours of work!

Everthing was workig fine until last week when I tried to plug in the drive and it did not come up in Windows Explorer.

Then I went to the WD Smartware and said it was “LOCKED” and needed to be re formatted!

I tried everything in the forums and nothing worked.

I am on XP and nothing showed up in Disk Management but I used another Windows 7 PC and it at least showed up in Disk Management but when I tried to INITIALIZE the drive it said it was “WRITE PROTECTED”

If anyone has any ideas please help.

And as for Western Digital I should consult a Lawyer and we should get a Class Action Lawsuit for people have lost their data and time\money to thees horrible drives.

If you are reading this and thinking about buying a WD My Book just go on the Internet and buy the CHEAPEST external hard disk and you will be doing yourself a favor as it will perform much better than these overpriced paper weights.

And I love how the Admins on this site try to blame it on us users.

I cant believe WD is still selling these drives with known problems!

Try going into Device Manager and delete the driver and SES driver for it then disconnect and reboot system. That should load fresh drivers when you reconnect.


I uninstalled the WD MY BOOK 1110 drive from device manager restarted  Windows XP and its not being detected.

No SES driver is in device manager.

Through WD Smartware I did the drive erase and its still locked and does not show up in Windows as a drive after many restarts.

Drive was fine for 2 years and then locked on me last week.

I had no idea what I was in store for at that time with all the data I lost.

Is this thing bricked now?

Should I call support and ask for a new one or do you have any other ides.

I have upgraded the WD Smartware program and did everything I can think of.

I am Microsoft Certified so if I havent found a fix yet I think its bricked.


I took my other 2tb WD MY BOOK 1110 thats working and it said SES device found and installed it and was able to be found in Windows Explorer and was assigned a logical drive.

Somehow the bad drive says theres a password on it.

How the drive automatically password locked is beyond me.

I cant even format it or upgrade the drive firmware using the WD Firmware Updater.

Keeps saying drive is locked…

Same with WD SmartWare.

Anyway around this?

I totally agree with you. I am thinking about taking WD to court myself.

This [Deleted] WD Element 1.5 TB is giving me grief to no end. When I first bought it 3 years ago it was broken after a week of use…and then it was repeated “delayed write fail” and then drive just stopped being recognized. I tried EVERYTHING and nothing worked. I finally found out that these external 1.5 TB Element drives are using Western Digital’s “GREEN” drives after I took it out  and plug it straight into my computer and it froze my computer periodically. I finally found a way to wipe the hard drive using low level tool and strangely enough, after wiping it it works again. 
So I started using it again, for the next 3 years it will work with occassional “delayed write fail” problem appearing when I copy large files. But just yesterday it happened repeatedly whenever I plug it in until this drive just basically fail itself out.

Luckily I learned my lesson last time so I did dual backup to another drive.


Totally agree. I’m digging into the WD design flaw. Any information is good.

My computer can’t recognize the WD essential.

I did several attempts.

If I opened the data guard software, then plugged in the USB, the software could recognize the drive, but the software showed NOT RESPONDING.
If I plugged in the USB, then opened the software as admin, the software showed 'detect drives" and then the window disappeared. There was no window of data guard. Once I unplugged the USB, the software windows showed up.