WD My Book Duo data forever lost if Drive Enclosure Dies!

I was thinking of buying a My Book Duo for my Mac because I wanted to use it as storage. Plus I liked the idea of using RAID to protect my data. However, based on some comments, I am not sure due to the enclosure and encryption issues.

I guess I will need to read the whole thread to make the decision on buying this unit or not.

I wished I have read this before buying the My book duo 20TB, too!
I bought this unit to use it as a RAID1 backup, but now I have a lot of concerns about it!
Unfortunately I cannot return the unit… and 10TB would be a lot of data to backup on other devices just to feel safe :frowning:

However, according to answers ID 4172 and 2658 WD says that in case of controller failure, you can still access your data using a new unit.

Maybe they improved the firmware meanwhile?
Does anybody tested it again recently?

I’m asking this because I’m at a crossroads, now:

  • Take out both disks and use them on another more secure enclosure, losing warranty.
  • Trust WD and starting using My Book Duo.

What do you think about it?
Any advice?

Thank you.

I realize this is an older thread, but hopefully someone still reads it/can help.

We think the enclosure of our 12TB Duo recently failed. When connecting to a power source, the Duo makes a ton of noise (fan?), but will not be recognized by the PC it’s connected to nor does the white LED light come on.

We have them in the JBOD (individual drives) configuration, but they’re still encrypted. According to this link, as long as the actual individual hard drives are intact, the data can be recovered and read with another WD enclosure: https://support-en.wd.com/app/answers/detail/a_id/1837

I guess my question is:

  1. Could I just buy an enclosure 2nd hand off ebay or some place? Even if it’s been used before?

  2. We have another of these Duos, same enclosure type. Could we take out the hard drives from this one, put in the ones from the failed enclosure, read out the data, and put the original ones back in or will this somehow mess up encryptions and render 4 hard drives unreadable in the process?

Thank you!

1 Like

I believe both of those solutions would work @siniang.

My issue was a single failed drive and it was resolved by me removing the failed drive from the enclosure and running a single drive. I them promptly copied my data off, bought a true NAS with raid, and promised myself never to buy Western Digital again.

2 Likes

Thank you!

Does it have to be the exact same WD My Book Duo enclosure or could it be single-drive My Book enclosures? Is that what worked for you?

Probably the exact same model.

1 Like

I’ve made the mistake of using a WD My Book Duo to archive data in raid 1 configuration. I powered up the disc recently and just got a flashing red light for one of the discs. Not a problem I thought - I’m using Raid1 so I should still have access to my data, but no - the disc wouldn’t mount. Odd I thought, but not a problem, I’ll take the good disc out and mount it directly with a caddy, after all that’s the point of Raid1, that you have two independent copies of the data. But no, the good disc wouldn’t mount either. Good disc gets put back in the WD caddy it came from and WD tool simply say there is a raid configuration problem and that the disc needs re-formatting. I then tried various recovery tools on the good disc without success. Eventually I sent the whole disc system to a recovery company and I’m now looking at £4900 to get my data back. Thanks WD. The least you could have done is made it clear that the discs can’t be accessed outside of the WD caddy. Frankly I’d have been much better storing my data on a single dumb disc. At least then I could have probably used recovery tools to get some of the data back.

1 Like

You all have me worried… my 9 year old My Book Duo has been great all these years. A little while ago I scored two higher capacity NOS drives and easily upgraded the whole setup. But because it is so old, I decided to pick up a used USB 3.0 version of the unit (the gray one) and hope to simply swap in my current drives. I am not as tech-savvy as some of you when it comes to RAID, but now, after reading all your posts, I am a bit scared!!

I had this SAME thing happen to my WD MyBook Duo with Raid 1 configuration. I needed to upgrade and build a server and took the disks out and tried to run them in the new box with some extra drives. They would not mount. After much research I put it all back together and tried to use in the my old computer as it did before. Now it says one disk is bad and will not read the drives. When I run the diagnostics that came with the WD it says everything is fine. PLEASE TELL ME THERE IS ANOTHER WAY TO GET MY DATA BACK.

1 Like

Add me to the list…

I purchased a My Book Duo 16TB in FEB of 2018. Yesterday i go to access it and Windows can’t find the drive anymore. The WD Utilities sees the Duo but says its un-configured for raid and there are no drives attached. When I plug in the power supply the fan whirrs for about 1 second and stops. No drive spin.

I called WD support and they said they do not offer any form of data recovery but I can go with a third party company to get my data back. They will send me a replacement but the old drives would not work in the new enclosure…

Has anyone found a way to get their data back?

I sure hope you didn’t have to spend over a thousand dollars to get your data back! You were quoted over $5,000 USD? Wow, I’m in the wrong business, well actually I wouldn’t work in that business to extort money out of desperate people. Contact WD, they know how to get your data back, they can tell you how, “if you get the right person”. I had saved some notes somewhere on the subject, maybe I can find them. WD should have simply OFFERED us their customers a piece of SOFTWARE that would let us READ our WD My Book Duo drives inside any computer. AND “ideally” they should encrypt our data with encryption key that WE provide so that only we can “read it”. The IRONY is that these days many people buy products like this and are locked out of their own DATA. Yet if the manufacturer gets their drive, or someone else (many 3rd parties do) with access to the manufacturer key and info can read their data without any problems. Its like good old “SKYPE” encryption, they gave the “Keys” to various governments like China so that they can read/eavesdrop all of that supposed “encrypted” communication. Encrypted from who? The pigeons in your attic? Since seems anyone else who matters can get the decryption keys, oh everyone except YOU :slight_smile:

When we buy a product with encryption, we should OWN the encryption keys used to encrypt, not just the password we make and we should be able to decrypt the drives outside of their proprietary enclosure and retrieve our data.

1 Like

I hope it’s not too late for me now!!!

I used WD My Book Duo (S/N WUA270….) (P/N WDBLWE…) 8TB configured as Raid 1, No Encryption for many months, stored about 3TB of data

Suddenly, the enclosure went faulty WD HDD not showing on the Windows Explorer and therefore cannot read my stored data. Furthermore, the WD HDD will show as Unallocated on Disk Management screen asking to format before using …

Using Recoverit application on one of the HDD raid 1 set, it could only recover some data not relevant at all to what I was looking for (such as .swf file extension, unreadable after recovery), and I cannot see any of my data although WD HDD shows it contains more than 3TB of material on Diskpart application.

I have second HDD from Raid set untouched, which I believe both HDD were working just fine when the WD My book duo PCB Controller went faulty …

Anyone can help to retrieve my data, knowing that repairing faulty PCB or swap replacement will not necessary allow to read HDD again, as PCB contains the firmware & encryption etc. and it’s not possible to mimic that. Plus all of this has to go through matching mechanism and removal procedures …

Anyone can Help, Please.

Hi, want to add some personal experiences with WD My Book Duo.

I bought two of these with 10TB disks (because of a good price)
I immediately moved the drives into my primary linux server without any problems.

I also have a backup server with several 4TB disks that has ran out of internal SATA ports. I read somewhere that the DUO should accept any WD red or WD green disks, so I moved two of my WD reds from my server any pu them into the DUO, connected it with the USB cable and was expecting the RAID to come online.
Unfortunately that didn’t happen, the disk labels weren’t read properly from the DUO.

After reading earlioer comments I guess I shouldn’t be too surprised,

So confirming the weird behaviour of the DUO I inserted a 3TB WD green disk into the DUO, connected it to my Win 10 PC and created an NTFS partion were I manged to store data without any problems.
Removed the disk from the DUO and connected it to a SATA port in the same computer.
The result was that the disk wasn’t readable.

So I can hereby confirm that the controller in the DUO is doing weird things with the disks, even if confured as JBOD.

Has contacted WD support after my first findings, without getting any feedback.

1 Like

Hi everyone,

first of all, I want to thank you all for sharing your experience! This is a very ugly problem and WD shall finally address this topic properly.

I bought my WD My Book Duo (WDBLWE…) about 7 years ago and so far, it was working fine. Finally I came to the point where both 3TB drives in RAID1 were occupied. So, I just ordered two new 4TB WD Red drives. I replaced the old disks with the new ones and re-configured the new drives. They were empty and ready for use … so far so good.
Now I wanted to transfer some of the most important data from the old to the new drives. For this reason, I tried to connect one of the old drives directly via SATA to my PC (bad idea). The disc couldn’t be read. This is where I stumbled across this whole “encryption topic”. I put the one old drive that was connected to my PC back into the enclosure (the other drive was already removed). But I couldn’t access any data anymore. When I connected the drive to the computer, I just tried to mount it (no formatting or initialisation!).
I tried a similar scenario with my new 4TB drives:

  1. Initializing both new discs (RAID1)
  2. Copying some test data onto them
  3. Removing disc 2 => disc 1 was working alone (data could be read)
  4. Connecting dist 2 to my PC => no reading possible
  5. Remove disc 1 and reinstall disc 2 to the enclosure in slot 1=> nothing could be read anymore
    … tried many more things but I couldn’t access the data on the new drives anymore.

Can someone of you answer one of the following questions:
Q1: Can you swap both discs of a working RAID1 without any problems or do I have to put the discs always back to THEIR INITIAL SLOT?!
Q2: Where is the encryption key located (disc or enclosure)?!
Q3: Can I access the encryption key even if I initialized two new drives in the meantime?! This question is related to the scenario of removing two occupied discs and installing two new discs… but to a given time you want to access your old data again and you load the enclosure with the old drives again.
Q4: I still have one of the old discs that has never seen anything than the My Book Duo. It was never connected to my PC directly. Would it be possible to insert it to its original slot and get my data back even if I have initialized some new drives in the meantime (similar to Q3)?!

Thank you so much for your help. I really hope that I will get my data back. I’m a passionate semi-professional photographer and all my images from the last 8 years are located on those drives…

I wish you all the best!
Cheers
Florian

1 Like

Hi Harhinai,

I’m sorry for your loss. I have a very similar problem. Recoverite was able to read almost all my old data from a single HDD that I connected previously to my PC via SATA. But the drive wasn’t working together with the enclosure anymore since it was connected to my PC.
Recoverite could detect almost all my folders and files and copied it to a new drive. After one night of scanning the disc and about 10h of transferring the files to a new drive, the disappointment hit me. The data could be copied but is all encrypted. It seems that Recoverite just copied all the data including the encryption. Not chance to open them under WIN10.

WD: WHY ARE YOU PUNISHING US ALL WITH THIS UNWANTED ENCRYPTION?! This is the most senseless thing that I have ever experienced with a RAID 1 drive!

One is for sure: I’ll never go for a WD product again!
All the best!
Florian

Thrown my WD Book in the bin. Pulled out the drives and mounted them in external caddies. Reformated and use a PC based RAID program running on an old HP as an external server.
WD, your customer service stinks, you are as bad a Samsung and that is saying something!

Wow, this thread is something else. Unbelievable.

Except it’s all documented here and at https://support-en.wd.com/app/answers/detail/a_id/1837

I just bought a WDBBGB 6TB. AKA WDBBGB0060HBK. It’s on the first row of the table at the URL above so it looks like I’m not in danger/don’t have too much reason to return it. I went with WD after noticing that their drives fail less often than their two competitors. Still, having second thoughts.

@jeff-Fike You should have kept the enclosure to sell to someone else on this thread who needs it to recover their data!

Cooperate, folks!

So I bought the 6TB one about 2 years ago to back all my photos up. I was sold on the idea of the mirror as being an easy & secure solution.

I’m having the same issue as siniang and I’ve only just unpacked the unit! :rage:

After googling solutions to the issue I stumbled across this forum. I hope to get a solution from WD support when I call but after reading the many years of complaints I am not expecting much.
Pretty ■■■■ considering the expense!

This is one reason to have more than one backup of your critical data.

For all of you who decided to move away from the WD My Book Duo enclosure,
what brand/model did you decide to go with ?

I am afraid that I also will need an enclosure replacement.

Click here to see my current issue.