WD My Book Duo data forever lost if Drive Enclosure Dies!

My post was removed as spam/advertising.

If you want instructions on how to mount an encrypted My Book after you remove it from the enclosure, look for the reallymine project on github. The program makes a decrypted image of your disk.

If you want to mount the disk in linux, look in the forum of reallymine for my PDF of instructions.

Sorry, I can’t offer to help you. That would be spam/advertising.

Good luck.

2 Likes

Absolutely. You cannot advertise on the community without permission from WD. If you were to continue to do so, you would get banned.

I don’t ask for money, only to help. The return I get is that it helps me develop my methods. I don’t consider that advertising.

WD can ban me if they want to. They don’t want people to know that their encryption is so weak.

1 Like

I have had no problem getting answers from Western Digital, although it wasn’t via this forum, it was via their site support section. Can’t complain about the service.

What I have been told is

  1. The encryption is set by the security utility, if you don’t want the encryption then don’t install the security utility.
  2. When using the Duo in Raid (0 or 1) without the encryption and you remove a disc to plug it into a computer directly or via a usb dock and you can’t access your files it is because it is set for Raid and you are putting it into a non Raid environment or if you put it them into a raid eviroment and it doesn’t work it is because the raid config isn’t exactly the same as the WD.
    -They did not say this bit; you can use software to retrieve your files, but after you will have to reformat to use the disc normally in the non raid enviroment.-
  3. You can put the disc into another Duo that is set up with the same raid configuration and read the discs.
  4. If you want, the Duo can run in JBOD, where each drive is seen individually and the discs are able to be used outside the Duo as long as you didn’t use the security utility.
    -(This has now been proven to be wrong, JBOD is still a Raid set up and as such is unreadable outside of Duo enclosures).

So I have ordered a simple 2 bay dock and will ditch the Duo enclosure. Will have to do a bit of mucking around to transfer the files twice, but better in the end.

Another issue I have faced with the Dou is the sleep function. If it is on and the drives sleep they disconnect from the computer. You have to turn the power off and on again to get it to reconnect. I turned the sleep off thinking the drives would spin down if not used for a while, but no they just keep spinning. The dock I have ordered just spinds down and is still viewable on the pc, clicking on the disc starts it spinning again.

I am new to the forum, and was looking to ask a question about adding new drives to my My Book Duo enclosure, as I am almost out of space. (500GB)

Then I saw this topic, and started to worry.

THEN I noticed the dates of the posts. My drive is 2007-2008 vintage or so, and I have had (knock on wood) no issues other than having to replace the USB cable and using an external fan to cool it in summer.

How do I know if my drives are encrypted like everyone’s here? I have always assumed that I could just connect to the drives if I needed to and access the info. Now I NEED to know for sure.

Curious…

Same problem here. But i’ve managed to recover the data on the Duo using RAID recovery on a PC workstation.
I use RAID 0, i just pulled off both Duo drives and load it to my windows machine then Run the RAID recovery.
Both drives are healthy.

But this will need a paid license in order to recover the data structures from Directory level. I use free trial, which only allowed me to do files copy only.

I thought it was an OS X problem, I’ve managed to bring it back to live after recover OSX from Time Machine, the duo was mounted. but then randomly ejected again.
so i assume that the duo enclosure was defective.

I’m so stressed now, i’m trying to recover the data to my Promise Pegasus R4 Thunderbolt but there’s no way to doing it on my PC.

Here’s my original post:

The RAID configuration from the DUO was on the DRIVES. same like software RAID or OSX RAID. so actually you can just pulled off and put it in your PC / old Mac Pro SATA slots (some says that you can use any enclosures that support RAID, but then configure it as a JBOD). then try to rebuild RAID by reading it’s existing RAID config on the drives. This will NOT delete the Data nor the existing RAID config.

What USB cable? Thunderbolt Duo doesn’t have any USB ports

Mine isn’t a Thunderbolt and does have a USB connection.

Hello people,

I just found about this issue while researching the purchase of a new MyBook drive, and I am gobsmacked.

I already have a MyBook, P/N WDBFJK0040HBK-04 . Does this model have this problem? I see most people here seem to have Duos and 8TB ones that use RAID1. I never turned on protection or installed any security software, for what it’s worth.

Just want to make sure to transfer my data to another drive before I run into an issue, and use this enclosure as landfill :@

Thanks !

1 Like

I just bought this external and I believe I have the same annoying 256-bit encrypted PCB bit as well…https://smile.amazon.com/gp/product/B01LQQHLGC/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1 My question is that I bought the data recovery plan add-on for $9.99 and I wonder what will happen IF the PCB does fail, if Seagate will be able to recover my data anyways…

Does anybody know if the newer MyBook duo’s still suffer from this problem (data on harddisks not usable outside the enclosure) ? WD changed the look of the enclosures completely, but kept the old name.

WDBFBE0200JBK-EESN 20TB
WDBFBE0160JBK-EESN 16 TB
WDBFBE0120JBK-EESN 12 TB
WDBFBE0080JBK-EESN 8 TB
WDBFBE0060JBK-EESN 6 TB

I finally purchased the Lacie 2big Thunderbolt 2 with 12TB of storage. With this drive in RAID1, I CAN take one of the drives out, put it in a PC and directly read and use my data. That’s how RAID1 should be done, WD used to know this too. So I wonder, if the new enclosure (with the old name) brought this functionallity back ? Thanks !

1 Like

What a simple 2 bay dock did you ordered? Thank you

Hello,

I bought a My Book Duo less than one month ago. My goal was to be able to backup critical data (synchronising important folders from my workstation to the external drive), and to archive less critical but huge folders and files.
I’m using it in RAID 1.

I also feel very concerned about the fact the data could be lost in the case the enclosure fails.
That inability to recover data by just pluging one hard drive to the computer and get the files back is disappointing, especially as this is really not obvious. Hopefully I did read this post so I am aware.

Could you WD please :
1 - make sure your customers are aware of this when buying your product. Not knowing that, people would rely on a not reliable solution. And this could lead to a personal desaster some time later.

2 - Let us know if this is possible to evolve the product, maybe with a firmware update, so we can disable encryption.

3 - Propose a solution / a recovery process in case the enclosure dies and data has to be retrieved from the discs

Thank you

Hi,

I was thinking of purchasing one of the my book duo (new redesign ones). However, after reading this post and other numerous users about this issue. It does make you not want to buy it. According to this https://support.wdc.com/knowledgebase/answer.aspx?ID=18358 > "Will I lose my data is the hardware encryption is not used and the enclosure needs to be replaced?
The encryption is always turned on and cannot be configured. The data is not lost. If the My Book Duo enclosure fails, replace the My Book Duo enclosure. Make sure that the My Book Duo firmware is the most recent, the move the HDDs in the replacement enclosure of the My Book Duo. The data should be available without any other configuration."

I’m assuming that means if the enclosure fails you can just get a replacement one and you should be able to access the drives again.

I purchased a My Book Duo 12TB and configured it in RAID 1, I never selected encryption but it sounds like it’s automatic. My Duo has been offline for days so I reseated the two drives and tried that. Then I removed Drive 2 and tried alone, no luck. Then I removed Drive 1 and tried it alone --> it mounted. I’m now copying all my data from this drive to another external for now.

I have no idea whether the My Book Duo controller is failing or if my Disk 1 failed. I got no kind of warnings or instructions from the My Book Duo to let me know there was a problem and to switch from the primary to the secondary drive.

Anyway, I need a new RAID setup, I don’t trust this controller and the Lacie 2big’s have very few and poor reviews on Amazon. What to do? Does anyone have the new My Book Duo model with latest firmware and have you tested pulling out a single drive and mounting it directly (as I agree, you should be able to do in any RAID 1 setup)?

–David, NYC

Data Recovery - My Story Duo

  1. I bought a my book duo 20tb (NEW!)
  2. I Set it up as raid 1 and copied data to it
  3. I bought a spare enclosure (2nd hand amazon)
  4. I Took out disk 2 of the raid 1 and put it into slot 1 of the new enclose (as a fail test)
  5. Bingo! i had 2 enclosures with access to my data on both (as degraded raid 1)

I am trying to put the 2 drives back together in one enclosure
But I this is no longer allowed - “Unknown raid configuration”
All is not lost…
If I take the drive out again…all is good i can get at my 6TB of data (with degraded warning)

If anyone knows how to force a raid rebuild I would be a happy bunny

!!! - UPDATE - 1 !!!

It seems the act of placing the disk into a new enclosure, allows access, but flags the firmware as…
“You can’t ever use this disk again with the old raid 1” - Buy a new drive dummy
I formatted it and initialised it in a hp micro server everything does not work
Even you own tech support gave up and said do it all again from scratch
HMMMM raid 1 is supposed to rebuild - what is this 1970’s

WD you must hate all of us so much to make data recovery so impossible
encrypted drives, no force raid rebuild etc etc etc
I can see why now everyone just buys you stuff for the disks and throws the enclosures in the trash

Very disappointed now i will have to start from scratch and spend another week copying over all files again

!!! - CONCLUSION - !!! - THE END

It alowed me to create a NEW Raid 1 array using the disk it wouldnt allow me REBULD with!
And copy all my data back on to it AGAIN!.. (In the process will take days).
We need a BIG RED BUTTON TO REUILD RAID 1 using disks we already own, but used elsewhere

So…

As long as you buy 2 enclosures you can Recover your Data if the enclosure fails
A Spare enclosure will allow you to copy your 10TB off of it to another device - at a price!!

After you do this your disk will NOT be usable as a Rebuild disk (some enclosure firmware edit/corruption/poisoning)

You will need to…

  1. You willl need to PURCHASE a new 10TB drive to rebuild (Or get WD to make a forced REBUILD button)
  2. Or you have to Copy the data off your 10TB drive and then make a NEW Raid 1 from your disks then copy it all back again.

End…

This past week I’ve been dealing with a MAJOR data loos on my crappy WD My Cloud EX2 Ultra.
The tech support that hardly speaks English is a joke and not really there to help, more like avoid answers and give you the run-around.
I personally find it beyond ridiculous that a company that’s been manufacturing Data Storage hardware for decades does no provide solutions for data loss/recovery while they have ALL the experience and knowledge to do so.
The amount of users on this forum that complain about Data loss on WD products SPEAKS VOLUMES!
Shame on you Western Digital. On your poor dysfunctional products and worse customer support and problem solving capabilities!
Shame on me (and everyone else) if I ever purchase any of your products again.

2 Likes

[quote=“notthesame, post:54, topic:6496”]
Lacie 2big Thunderbolt 2 with 12TB
[/quo

The enclosure of my new Mybook duo 20TB failed (after just 1 month) and I cannot access the data (set as raid 1). I wished I have read this earlier before. I thought raid 1 setting is safe and so with no other copy of the data. I have read so many posts but I am really not sure how to do before going to a data recovering company. What should I do? Many thanks!

I was thinking of buying a My Book Duo for my Mac because I wanted to use it as storage. Plus I liked the idea of using RAID to protect my data. However, based on some comments, I am not sure due to the enclosure and encryption issues.

I guess I will need to read the whole thread to make the decision on buying this unit or not.

I wished I have read this before buying the My book duo 20TB, too!
I bought this unit to use it as a RAID1 backup, but now I have a lot of concerns about it!
Unfortunately I cannot return the unit… and 10TB would be a lot of data to backup on other devices just to feel safe :frowning:

However, according to answers ID 4172 and 2658 WD says that in case of controller failure, you can still access your data using a new unit.

Maybe they improved the firmware meanwhile?
Does anybody tested it again recently?

I’m asking this because I’m at a crossroads, now:

  • Take out both disks and use them on another more secure enclosure, losing warranty.
  • Trust WD and starting using My Book Duo.

What do you think about it?
Any advice?

Thank you.