WD My Book 8tb not showing on WD Live TV Hub Media Center

Not sure where to post this so… sorry if this is the wrong category.

I just bought an 8tb WD My Book and it is not showing on WD Live TV Hub Media Center. I bought it to replace 2 WD 3tb My Books that were connected to the media center. Any ideas?


I have a similar post about my 6TB drive not being seen by my WD Media player. From what I’ve researched I’ve found…

  • Drive can’t be formatted using exFAT… needs to be NTFS
  • conflicting posts say it must be partitioned MBR not GPT but MBR is (or not according to some posts) restricted to 2TB
  • some people report no problem up to 5TB but my player will see a 1TB drive but not a 3TB or 6TB drive

I’ve made posts on several forums but haven’t gotten any replies. Apparently there’s a way to format an MBR partitioned hard drive using 4k allocation which will get you to see up to 16TB but I can’t find anything about how to do that either.

Good Luck, please let me know if you find anything.

Cheers! - Mike

Another update…

I’m at my wits end and will likely just throw the media player in the garbage.

I thought I finally found the answer with this post…

“Long story short, I used the WD quick formatter tool (Google it) to format the 6TB drive with Windows XP settings (not Vista & above), which formatted the drive as MBR 6TB. My WD TV Live recognised it but didn’t show the drive until I copied video files to it. Now working as expected. I tried everything else, this is the only solution that worked for me.”

I downloaded the quick formatter, reformatted it to be XP Compatible, I confirmed using my Disk Management tool in windows that it’s showing MBR partition style and one 6TB volume. Ecstatically I ran to my media player and plugged it in. It’s still not $#%&@# showing the drive. I’m out of ideas and options.

Hopefully the above works for you. Note: the WD Quick Formatter tool won’t give you the option window to choose “XP Compatible” if you’re using Win 10 like me. You have to first check properties of the actual formatter .exe file and have it run in Win 7 compatibility mode.

Good Luck!

Sooo… I decided to give up on the 6 TB MyBook external drive. The old drive that I was using for years (but is now getting too small) is a 3 TB MyBook. I reformatted and repurposed the 3 TB but I figure it’s better than nothing and I can offload movies that are older so that the 3 TBs will be enough. Guess what? NOW the 3 TB isn’t recognized either! There is something in the formatting of the drive that makes them unrecognizable to the WD Media Player. I don’t know what it is and have run out of ideas but surely SOMEONE at Western Digital SOMEWHERE knows why a WD drive won’t play with a WD Media Player wouldn’t you think? And yet with all posts and searching nobody seems to be able to give us poor slobs that invested in WD technology an answer. I really don’t understand…