WD My Book 4TB reformatted to ex-fat won't update

I have a 4TB My Book western digital drive that was used for backup to my windows laptop. I now have an iMac. I tried reformatting My Book to ex-fat because I thought that was what I should do. My iMac was formatted with a partition for files from my windows laptop. I don’t know if ex-fat is the right system to use on My Book. It copied 151GB. (I think). But its not updating correctly. I got it to update once by turning off my computer and initializing everything again. Theres a couple more updates on there I got by accident, but most of the time I get:
"Could not back up MY BOOK. Error occurred while creating a backup folder.
What should I do to correct this?

Hi,

You could refer to the following links:

https://support-en.wd.com/app/answers/detail/a_id/8200

https://support-en.wd.com/app/answers/detail/a_id/24863

Hi, if you want to use your My Book specifically for iMac then I would advise you to back up your My Book and format it to APFS. Ex-FAT is a helpful filesystem however it’s useful when you require to transfer data from a Mac to a PC.

I put 151 gb on MY Book already. I think it only copied files from the iOS side of my iMac. So it won’t matter if I delete what’s there already. Now my next question is the format. I went to the manual for my book and it recommended
HFS+. I do wish to use it for iMac only. But, when I got my iMac, I was able to transition my Sony files to a partition on it. So, if I get My Book loaded correctly and formatted correctly, will it still try to copy files from my Sony in the partition on my iMac causing an error in updating?

Im still having trouble. First: The title here says reformatted to ex-fat. Not the case. It was reformatted to Mac OS. It won’t update after doing the first full backup for an hour.

I opened WD Utilities: MY BOOK passed all three.
I did a GET INFO. Info said I did not have permission to write. So I unlocked it and changed everyone to read & write. Now I had permission to use First Aid. First Aid said “couldn’t repair because it couldn’t unmount the disk.” So I tried to manually unmount the disk to “repair” and it wouldn’t let me due to the disk being in use.

My question is "If the utilities say My Book pass all 3 scans. There is no error?
If there is no error, why do I get the error message, Time Machine can’t backup, due to error occurring creating backup folder.

Does it still have to do with the error message that First Aid can’t unmount the disk to repair it? But utilities say there are no bad sectors.

UPDATE: Yesterday, I was just checking to see where I was at with straightening out MY BOOK. I was able to get to the page where I could unmount, first aid, etc. So, for the heck of it, I did unmount (making sure first I could read and write with permission), it worked. Yay. So I did First Aid. That worked. Another Yay. Summary said there was no apparent problem with my device. hmmm. So why wouldn’t it update? So I went back to the Time Machine, clicked on backup and lo and behold, it did it. This morning I went in and did a manual update and it did 285mb. Yay. I don’t know what I did right. Was it because I rebooted my computer at the right time? Was it because I clicked on Energy Saver and told the computer not to go to sleep when display is off? I don’t know. I don’t want to jinx myself, it is working. If it stops I may be back here woe be gone again. Thanks for all the helpful hints I received in the Knowledge Base and other peoples solving answers.