WD My Book 4TB Keeps on Disconnecting


I have a WD My Book 4TB External Drive.

I’m using Rabook Firebat F650 a.k.a. MSI Barebones MS-16F4 937-16F454-017.

I’m using Windows 8.1 Pro 64-bit.

The Drivers are Intel USB 3.0 eXtensible Host Controller - 0100 (Microsoft) ver. 6.3.9600.16506

The WD My Book 4TB keeps on connecting-disconnecting-reconnecting every few seconds/minutes when plugged to USB 3.0 port. This does not happen when connecting to USB 2.0 port.

I have tried (and failed) :

  1. Changing all the Power Plan USB Selective Suspend settings to DISABLED

  2. UNCHECKING all the USB Hub Power Management Settings in Device Manager.

  3. Updated the Firmware.

  4. Removing the Drivers and let Windows reinstall it.

  5. Using a shorter USB 3.0 cable from my TOSHIBA Canvio 1TB. (so it’s not the cable’s fault)

I have tried (and works) :

  1. Testing it on my old Lenovo Y470 (it works on my Lenovo Y470)

  2. Testing my TOSHIBA Canvio 1TB (it does not have this problem)

My assumption :

  1. WD My Book 4TB has problems with Intel eXtensible Driver :

-Because it works on my Lenovo Y470 (it uses Renesas Electronics USB 3.0 Driver)

-Because my TOSHIBA Canvio 1TB works on my Rabook F650 (with Intel eXtensible Driver)

  1. Other problems maybe? I need help on this mater.

Thank you for your help.



Check if you have the latest USB drivers installed for your computer. Also try having the My Book power cable connected directly to the wall when testing it on the computer that is having problems. 

I’ve had the exact same problem on my WD Portable Ultra 2TB HDD. The problem only started happening once I upgraded the firmware. So I sold it and now got a WD My Book 3TB but I have learned my lesson, I will not be upgrading the firmware. the firmware that my previous WD My Passport Ultra had was v1.025 if that matters.

WD does not offer its customers to downgrade the firmware so you are out of luck.

And to the staff member that suggested to update the USB Drivers! PLEASE for the love of God! what kind of technical support is this? Windows 8 does not need and does not have USB 3.0 Drivers. They are now built into the OS and there is no way of updating them!

1 Like