WD My Book 4TB - fails to mount

I have had a WD My Book 4TB for several years. Most of the time I’ve connected it directly to my laptop via a USB hub. More recently I connected it to my router and accessed it over the wi-fi network, but media transfer is slow over wi-fi. Today I hooked it up via USB again and it wouldn’t mount. Tried again over wi-fi and it won’t mount there either. It appears to have gone corrupt sometime in between.

I downloaded the latest WD Drive Utlis (v2.1.1.74) and ran the diagnostics. Complete Drive Test failed. It doesn’t give any further explanation or offer solutions to repair.

In Disk Utility, WD MyBook appears as an external drive. When I try to mount the volume, nothing happens. When I run First Aid, I get First Aid process has failed.

Invalid B-tree node size
The volume could not be verified completely.
File system check exit code is 8.
Updating boot support partitions for the volume as required.
File system verify or repair failed.
Operation failed…

The drive shows all 4TB data as “Used.” Last I checked it was less than 2TB. (It’s not my Time Machine drive and there shouldn’t be anything writing to it in the background.)

I’m running Sierra, 10.12.6., on a 4-year-old Macbook Pro.

Any thoughts as to how I can repair the volume? Or where I should start to recover the data?

Many thanks for any direction.

Hi,
Can you check spin conditions of it or record sounds when power up.

If your WD is there in Disk Utility as an unmounted volume then still you have fair chance to recover files. And you should recover it quickly before the unmounted volume disappears permanently. You can read about unmounted drive recovery https://www.stellarinfo.com/support/kb/index.php/article/how-to-recover-data-from-unmountable-drive

@alldataback I’m not sure what you mean by “spin conditions” and I don’t see how it would help to record sounds. When I connect it to my Mac directly, I do hear it spin up.

@DonaldKepler Thanks for the suggestion. I downloaded the Stellar Phoenix app; when I scan the Volume it says “No Data Found.” I’m running the scan on the drive now and it looks like it will take some time.
When I tried to run First Aid from Disk Utility, I got a prompt to run First Aid from Recovery. I tried that but got the same results (even from within Recovery startup, it tells me to run First Aid from Recovery).

can you show some screenshot of Stellar Phoenix?

Stellar Phoenix is troublesome. When I try Volume Repair, the app crashes as soon as I hit “Repair.” Then when I re-launch and try again, no volumes at all (including the startup disk) appear in the list (screenshot 1).

I also tried Data Recovery. This took untold hours to scan and “Recover.” The scan revealed 51 “volumes” in need of recovery. When I tried to recover the first, it created 10,488 folders labeled “Folder ###” and amounting to 180GB of data. This is partly successful because some of the folders indeed contain files I’d lost, but they’re scattered among these unnamed folders without any reference to the original directory structure. So finding a single file is excruciating, much less restoring, say, the iTunes library. And the files that were “restored” still seem corrupt: a CSS file contains gibberish (…ÒNþŽn˜¡Ë…) and a JPG won’t open because “an unknown or invalid JPEG marker type is found.”

That was the first of 51 “sectors” I tried to recover (which are actually all on one volume). When I scan any other “sector” I get “No data found.”

I saved the scan information (into a 124GB file). When I try to re-open it I get an error that says “It is not a valid scan file” (screenshot 2).

Frustrating.


My dear friend. I need some help and advice, even is not the exact question discussed here, could you help me?

do you try r-studio?

Haven’t tried R-Studio. Skeptical b/c its website looks older than my kid. I’m looking at Alsoft DiskWarrior, which I haven’t used or needed in ten years but came in handy then. Anybody here have luck with DiskWarrior?

DiskWarrior saved the day. Highly recommend.